summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2012-08-13 09:22:39 +0200
committerThomas Raschbacher <lordvan@gentoo.org>2012-08-13 09:22:39 +0200
commitfa97e21cace5ce3d10bd5efb1626608f0b9c7a3c (patch)
treee7479276266c5cfdcfb84b8d41395d1260986e43
parentfix typo in sed (diff)
downloadlordvan-fa97e21cace5ce3d10bd5efb1626608f0b9c7a3c.tar.gz
lordvan-fa97e21cace5ce3d10bd5efb1626608f0b9c7a3c.tar.bz2
lordvan-fa97e21cace5ce3d10bd5efb1626608f0b9c7a3c.zip
fix typo in sed again
-rw-r--r--media-tv/me-tv/me-tv-1.4.0.7.ebuild44
-rw-r--r--media-video/openshot/openshot-1.4.1.ebuild69
2 files changed, 113 insertions, 0 deletions
diff --git a/media-tv/me-tv/me-tv-1.4.0.7.ebuild b/media-tv/me-tv/me-tv-1.4.0.7.ebuild
new file mode 100644
index 0000000..3d1a32f
--- /dev/null
+++ b/media-tv/me-tv/me-tv-1.4.0.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils versionator gnome2
+
+DESCRIPTION="Me TV is a GTK desktop application for watching digital television."
+HOMEPAGE="http://me-tv.sourceforge.net/"
+SRC_URI="http://launchpad.net/${PN}/$(get_version_component_range 1-2)/$(get_version_component_range 1-3)/+download/${P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug doc nls static"
+RDEPEND=">=dev-cpp/libgnomemm-2.20.0
+ >=dev-cpp/libgnomecanvasmm-2.20.0
+ >=dev-cpp/libgnomeuimm-2.20.0
+ >=dev-cpp/gconfmm-2.20.0
+ >=dev-cpp/gtkmm-2.16.0
+ =dev-db/sqlite-3*
+ >=net-libs/gnet-2.0.0
+ >=x11-libs/libXtst-1.0.0
+ >=media-libs/xine-lib-1.1.7"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )"
+
+#S="${WORKDIR}/${PN}-0.8.0"
+
+src_prepare() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ || die "econf failed"
+}
+
+src_compile() {
+ gnome2_src_compile
+}
+
diff --git a/media-video/openshot/openshot-1.4.1.ebuild b/media-video/openshot/openshot-1.4.1.ebuild
new file mode 100644
index 0000000..8aa738b
--- /dev/null
+++ b/media-video/openshot/openshot-1.4.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+PYTHON_DEPEND=2:2.5
+PYTHON_USE_WITH=xml
+
+inherit distutils fdo-mime python
+
+DESCRIPTION="OpenShot Video Editor is a non-linear video editor"
+HOMEPAGE="http://www.openshotvideo.com"
+SRC_URI="http://launchpad.net/openshot/1.2/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dv faac faad flac ieee1394 mp3 ogg quicktime theora vorbis wavpack x264 xvid"
+
+DEPEND=""
+RDEPEND="
+ >=x11-libs/gtk+-2.18
+ dev-python/pygtk
+ dev-python/pygoocanvas
+ dev-python/pyxdg
+ dev-python/librsvg-python
+ >=media-libs/mlt-0.4.6-r1[dv?,ffmpeg,frei0r,gtk,melt,python,quicktime?,sdl,vorbis?,xml,kde]
+ media-sound/sox[encode,ffmpeg,flac?,ogg?,wavpack?]
+ >=media-video/ffmpeg-0.6[encode,faac?,faad?,ieee1394?,mp3?,sdl,theora?,vorbis?,vpx,x264?,xvid?]
+ "
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -q -r 2 .
+ distutils_src_prepare
+
+ # Disable the installation of the mime.types file.
+ # The .desktop file would be used to update the mime database.
+ sed -ie '/launcher/,+1d' setup.py || die
+
+ # Avoid stuff covered by fdo-mime.eclass
+ # (update-mime-database update-desktop-database update-mime)
+ # export "FAKEROOTKEY=gentoo" does not work as this variable is filtered
+ # by portage
+ sed -ie '/FAILED = /,$d' setup.py || die
+}
+
+# TODO: check stuff installed to /usr/lib/python2.6/site-packages as there are
+# some parts installed which shouldn't (locale, themes, profiles effects,
+# etc...) Afaik only python stuff should go there and the rest probably to
+# /usr/share/openshot
+# The same goes for /usr/lib/mime/packages
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postrm
+}