summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2007-07-14 14:16:34 +0000
committerMatti Bickel <mabi@gentoo.org>2007-07-14 14:16:34 +0000
commitfdf8fcc048976d583c16a6ebfa21ddcd2fcf0a2d (patch)
treec0b8117909bd3e5982d3d9589a02c4662c4ebd78 /x11-wm/ion3/files
parentFix manifest (diff)
downloadmabi-fdf8fcc048976d583c16a6ebfa21ddcd2fcf0a2d.tar.gz
mabi-fdf8fcc048976d583c16a6ebfa21ddcd2fcf0a2d.tar.bz2
mabi-fdf8fcc048976d583c16a6ebfa21ddcd2fcf0a2d.zip
version bump
svn path=/; revision=7
Diffstat (limited to 'x11-wm/ion3/files')
-rw-r--r--x11-wm/ion3/files/20070708/201_all_fix-paths.patch75
-rw-r--r--x11-wm/ion3/files/20070708/202_all_fix-menus.patch13
-rw-r--r--x11-wm/ion3/files/20070708/205_all_ion-lock.patch22
-rw-r--r--x11-wm/ion3/files/20070708/208_all_as-needed.patch12
-rw-r--r--x11-wm/ion3/files/digest-ion3-200707086
-rw-r--r--x11-wm/ion3/files/ion3-scripts-20070708.tar.bz2bin0 -> 102282 bytes
6 files changed, 128 insertions, 0 deletions
diff --git a/x11-wm/ion3/files/20070708/201_all_fix-paths.patch b/x11-wm/ion3/files/20070708/201_all_fix-paths.patch
new file mode 100644
index 0000000..cb27bfc
--- /dev/null
+++ b/x11-wm/ion3/files/20070708/201_all_fix-paths.patch
@@ -0,0 +1,75 @@
+--- ion-3rc-20070708.orig/system.mk 2007-07-14 12:40:45.000000000 +0200
++++ ion-3rc-20070708/system.mk 2007-07-14 15:54:39.000000000 +0200
+@@ -7,7 +7,7 @@
+ ## Installation paths
+ ##
+
+-PREFIX=/usr/local
++PREFIX=/usr
+
+ # Unless you are creating a package conforming to some OS's standards, you
+ # probably do not want to modify the following directories:
+@@ -15,7 +15,7 @@
+ # Main binaries
+ BINDIR=$(PREFIX)/bin
+ # Configuration .lua files
+-ETCDIR=$(PREFIX)/etc/ion3
++ETCDIR=/etc/X11/ion3
+ # Some .lua files and ion-* shell scripts
+ SHAREDIR=$(PREFIX)/share/ion3
+ # Manual pages
+@@ -56,18 +56,18 @@
+
+ # If you have installed Lua 5.1 from the official tarball without changing
+ # paths, this should do it.
+-LUA_DIR=/usr/local
+-LUA_LIBS = -L$(LUA_DIR)/lib -llua
+-LUA_INCLUDES = -I$(LUA_DIR)/include
+-LUA=$(LUA_DIR)/bin/lua
+-LUAC=$(LUA_DIR)/bin/luac
++#LUA_DIR=/usr/local
++#LUA_LIBS = -L$(LUA_DIR)/lib -llua
++#LUA_INCLUDES = -I$(LUA_DIR)/include
++#LUA=$(LUA_DIR)/bin/lua
++#LUAC=$(LUA_DIR)/bin/luac
+
+ # If you are using the Debian packages, the following settings should be
+ # what you want.
+-#LUA_LIBS=`pkg-config --libs lua5.1`
+-#LUA_INCLUDES=`pkg-config --cflags lua5.1`
+-#LUA=/usr/bin/lua5.1
+-#LUAC=/usr/bin/luac5.1
++LUA_LIBS=`pkg-config --libs lua`
++LUA_INCLUDES=`pkg-config --cflags lua`
++LUA=/usr/bin/lua
++LUAC=/usr/bin/luac
+
+
+ ##
+@@ -104,7 +104,7 @@
+ # asprintf and vasprintf in the c library. (gnu libc has.)
+ # If HAS_SYSTEM_ASPRINTF is not defined, an implementation
+ # in sprintf_2.2/ is used.
+-#HAS_SYSTEM_ASPRINTF=1
++HAS_SYSTEM_ASPRINTF=1
+
+ # If you're on an archaic system (such as relatively recent *BSD releases)
+ # without even dummy multibyte/widechar and localisation support, you may
+@@ -143,14 +143,14 @@
+
+ #C89_SOURCE=-ansi
+
+-#POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
++POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
+
+ # Most systems
+-#XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
++XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
+ # SunOS, (Irix)
+ #XOPEN_SOURCE=-D__EXTENSIONS__
+
+-#C99_SOURCE=-std=c99 -DCF_HAS_VA_COPY
++C99_SOURCE=-std=c99 -DCF_HAS_VA_COPY
+
+ # The -DCF_HAS_VA_COPY option should allow for some optimisations, and
+ # in some cases simply defining
diff --git a/x11-wm/ion3/files/20070708/202_all_fix-menus.patch b/x11-wm/ion3/files/20070708/202_all_fix-menus.patch
new file mode 100644
index 0000000..c2d77c8
--- /dev/null
+++ b/x11-wm/ion3/files/20070708/202_all_fix-menus.patch
@@ -0,0 +1,13 @@
+diff -Naur ../work/ion-3ds-20061223/etc/cfg_ioncore.lua ion-3ds-20061223/etc/cfg_ioncore.lua
+--- ../work/ion-3ds-20061223/etc/cfg_ioncore.lua 2006-12-23 17:59:43.000000000 +0300
++++ ion-3ds-20061223/etc/cfg_ioncore.lua 2006-12-31 15:35:59.000000000 +0300
+@@ -331,7 +331,8 @@
+ defmenu("mainmenu", {
+ menuentry("Run...", "mod_query.query_exec(_)"),
+ menuentry("Terminal", "ioncore.exec_on(_, XTERM or 'xterm')"),
+- menuentry("Lock screen", "ioncore.exec_on(_, 'xlock')"),
++ menuentry("Lock screen",
++ "ioncore.exec_on(_, ioncore.lookup_script('ion-lock'))"),
+ menuentry("Help", "mod_query.query_man(_)"),
+ menuentry("About Ion", "mod_query.show_about_ion(_)"),
+ submenu("Styles", "stylemenu"),
diff --git a/x11-wm/ion3/files/20070708/205_all_ion-lock.patch b/x11-wm/ion3/files/20070708/205_all_ion-lock.patch
new file mode 100644
index 0000000..dda2016
--- /dev/null
+++ b/x11-wm/ion3/files/20070708/205_all_ion-lock.patch
@@ -0,0 +1,22 @@
+diff -Nur ion3-20050322.orig/utils/Makefile ion3-20050322/utils/Makefile
+--- ion3-20050322.orig/utils/Makefile 2005-03-22 14:31:06.000000000 +0000
++++ ion3-20050322/utils/Makefile 2005-03-22 16:29:37.197355881 +0000
+@@ -11,7 +11,7 @@
+ SUBDIRS=ion-completefile
+ INSTALL_SUBDIRS=$(SUBDIRS)
+
+-SHELLSCRIPTS = ion-runinxterm ion-completeman
++SHELLSCRIPTS = ion-runinxterm ion-completeman ion-lock
+
+ TARGETS = ion-completeman
+
+diff -Nur ion3-20050322.orig/utils/ion-lock ion3-20050322/utils/ion-lock
+--- ion3-20050322.orig/utils/ion-lock 1970-01-01 00:00:00.000000000 +0000
++++ ion3-20050322/utils/ion-lock 2005-03-22 16:29:19.550092305 +0000
+@@ -0,0 +1,6 @@
++#!/bin/sh
++if xscreensaver-command -version >/dev/null 2>&1; then
++ exec xscreensaver-command -lock
++else
++ exec xlock
++fi
diff --git a/x11-wm/ion3/files/20070708/208_all_as-needed.patch b/x11-wm/ion3/files/20070708/208_all_as-needed.patch
new file mode 100644
index 0000000..662a078
--- /dev/null
+++ b/x11-wm/ion3/files/20070708/208_all_as-needed.patch
@@ -0,0 +1,12 @@
+diff -uNr ion-3ds-20070318.orig/de/Makefile ion-3ds-20070318/de/Makefile
+--- ion-3ds-20070318.orig/de/Makefile 2007-03-18 21:31:37.000000000 +0100
++++ ion-3ds-20070318/de/Makefile 2007-04-30 17:30:23.000000000 +0200
+@@ -17,6 +17,8 @@
+
+ MAKE_EXPORTS=de
+
++LDFLAGS+=-lXext
++
+ ######################################
+
+ include $(TOPDIR)/build/rules.mk
diff --git a/x11-wm/ion3/files/digest-ion3-20070708 b/x11-wm/ion3/files/digest-ion3-20070708
new file mode 100644
index 0000000..0f91241
--- /dev/null
+++ b/x11-wm/ion3/files/digest-ion3-20070708
@@ -0,0 +1,6 @@
+MD5 c9782f343d0c50bef81573644eb7e176 ion-3rc-20070708.tar.gz 655000
+RMD160 85947dc1b1dd7abd4304a42e2e946a7641cda8c4 ion-3rc-20070708.tar.gz 655000
+SHA256 f59eafbda1f13d5d21129c222a4c64b9ce7a4e7b3f9fd93bb739dfd5af1fca0f ion-3rc-20070708.tar.gz 655000
+MD5 42db17925e8e745c2385f1b42fa26f78 ion-doc-3rc-20070708.tar.gz 669854
+RMD160 ba3bdb7b4ca4331738faa0aa2501d662644d0a39 ion-doc-3rc-20070708.tar.gz 669854
+SHA256 d1651f219a43f413de618a7bf158ddbc42c2c3025807965271c97214bba10ef3 ion-doc-3rc-20070708.tar.gz 669854
diff --git a/x11-wm/ion3/files/ion3-scripts-20070708.tar.bz2 b/x11-wm/ion3/files/ion3-scripts-20070708.tar.bz2
new file mode 100644
index 0000000..f805089
--- /dev/null
+++ b/x11-wm/ion3/files/ion3-scripts-20070708.tar.bz2
Binary files differ