summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMATSUU Takuto <matsuu@gentoo.org>2010-11-23 09:43:45 +0900
committerMATSUU Takuto <matsuu@gentoo.org>2010-11-23 09:43:45 +0900
commit64e4934ae66eef179ccb66653483b9edcd2f5bd9 (patch)
tree3a945a82e0b5c841eb9a089072baeaa2348033b2
parentapp-backup/nautilus-dropbox: Version bumped. (diff)
downloadmatsuu-64e4934ae66eef179ccb66653483b9edcd2f5bd9.tar.gz
matsuu-64e4934ae66eef179ccb66653483b9edcd2f5bd9.tar.bz2
matsuu-64e4934ae66eef179ccb66653483b9edcd2f5bd9.zip
sys-auth/pam_yubico: Initial import.
(Portage version: 2.1.9.24/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--sys-auth/pam_yubico/Manifest4
-rw-r--r--sys-auth/pam_yubico/files/pam_yubico-2.5-nodebug.patch24
-rw-r--r--sys-auth/pam_yubico/metadata.xml9
-rw-r--r--sys-auth/pam_yubico/pam_yubico-2.5.ebuild38
4 files changed, 75 insertions, 0 deletions
diff --git a/sys-auth/pam_yubico/Manifest b/sys-auth/pam_yubico/Manifest
new file mode 100644
index 0000000..cebcf50
--- /dev/null
+++ b/sys-auth/pam_yubico/Manifest
@@ -0,0 +1,4 @@
+AUX pam_yubico-2.5-nodebug.patch 741 RMD160 429d3ffb1d5fb580a02d97b2a9cc3304a38360a7 SHA1 25dfc11a4c2e6cf73bbdc97ab2806aca419ef5cc SHA256 1cc535429b41ea8b765c354a05ff17a6d6e899df35da1d6b508abaf558cce430
+DIST pam_yubico-2.5.tar.gz 312521 RMD160 6b4b839f61d16f344054f7cdcf029b09420ff68d SHA1 ed585edbd379cec3df60365c4e61977b9dc5af1c SHA256 fc60f4311d1c1a8f1cee9dae9a72942e85a702f44fcf08dc359a854f08c01178
+EBUILD pam_yubico-2.5.ebuild 771 RMD160 69be9b5c3cf6e69eccb15c9fde5c104d5b4dce10 SHA1 f6083a844649e049f357b677f30281326710338b SHA256 e2037109f3c8f136ee136208df58d5387590af686904f7ba9024fa5cb66e045a
+MISC metadata.xml 221 RMD160 ca5e46f2e947fcae430e49859acaa4b25ab9d4b4 SHA1 b7f58eb04a9aceeb67104c0b81719e6e97da97f4 SHA256 138123f5d6199cbcc391346419b7b81d3ae9153c17670b18c540ff75a2287371
diff --git a/sys-auth/pam_yubico/files/pam_yubico-2.5-nodebug.patch b/sys-auth/pam_yubico/files/pam_yubico-2.5-nodebug.patch
new file mode 100644
index 0000000..ed1bd9f
--- /dev/null
+++ b/sys-auth/pam_yubico/files/pam_yubico-2.5-nodebug.patch
@@ -0,0 +1,24 @@
+diff -Naur pam_yubico-2.5.orig/Makefile.am pam_yubico-2.5/Makefile.am
+--- pam_yubico-2.5.orig/Makefile.am 2010-09-10 17:42:19.000000000 +0900
++++ pam_yubico-2.5/Makefile.am 2010-11-07 09:56:08.790170862 +0900
+@@ -37,7 +37,7 @@
+ pam_yubico_la_LIBADD = @LTLIBYKCLIENT@ @LIBLDAP@
+ pam_yubico_la_LDFLAGS = -module -avoid-version
+
+-DEFS = -DDEBUG_PAM -DPAM_DEBUG @DEFS@
++DEFS = @DEFS@
+
+ # Self tests.
+
+diff -Naur pam_yubico-2.5.orig/pam_yubico.c pam_yubico-2.5/pam_yubico.c
+--- pam_yubico-2.5.orig/pam_yubico.c 2010-09-10 06:38:07.000000000 +0900
++++ pam_yubico-2.5/pam_yubico.c 2010-11-07 10:01:46.348254257 +0900
+@@ -61,6 +61,8 @@
+ printf ("\n"); \
+ } while (0)
+ # endif
++#else
++# define D(x) ;
+ #endif
+
+ #include <ykclient.h>
diff --git a/sys-auth/pam_yubico/metadata.xml b/sys-auth/pam_yubico/metadata.xml
new file mode 100644
index 0000000..5b14597
--- /dev/null
+++ b/sys-auth/pam_yubico/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>matsuu@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
+
diff --git a/sys-auth/pam_yubico/pam_yubico-2.5.ebuild b/sys-auth/pam_yubico/pam_yubico-2.5.ebuild
new file mode 100644
index 0000000..353c25b
--- /dev/null
+++ b/sys-auth/pam_yubico/pam_yubico-2.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+inherit autotools eutils pam
+
+DESCRIPTION="Yubico Pluggable Authentication Module (PAM)"
+HOMEPAGE="http://code.google.com/p/yubico-pam/"
+SRC_URI="http://yubico-pam.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ldap"
+
+DEPEND=">=sys-auth/ykclient-2.3
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if ! use debug ; then
+ epatch "${FILESDIR}/${P}-nodebug.patch"
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_with ldap) \
+ --with-pam-dir="$(getpam_mod_dir)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc ChangeLog NEWS README doc/* || die
+}