summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMATSUU Takuto <matsuu@gentoo.org>2009-12-02 23:28:23 +0900
committerMATSUU Takuto <matsuu@gentoo.org>2009-12-02 23:28:23 +0900
commite09d2386b1369ae8cc1054808695e82baf8a6351 (patch)
tree0204160863afcef7fe949291c587b8ede1f6374b /x11-misc
parentx11-wm/musca: already in portage tree. (diff)
downloadmatsuu-e09d2386b1369ae8cc1054808695e82baf8a6351.tar.gz
matsuu-e09d2386b1369ae8cc1054808695e82baf8a6351.tar.bz2
matsuu-e09d2386b1369ae8cc1054808695e82baf8a6351.zip
x11-misc/notify-osd: Version bumped.
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/notify-osd/Manifest2
-rw-r--r--x11-misc/notify-osd/notify-osd-0.9.24.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/notify-osd/Manifest b/x11-misc/notify-osd/Manifest
index 3b78b23..9ec9668 100644
--- a/x11-misc/notify-osd/Manifest
+++ b/x11-misc/notify-osd/Manifest
@@ -3,6 +3,8 @@ AUX notify-osd-0.9.12-gentoo.patch 475 RMD160 aa33ded46e48c4992b250550d49d0d6e8f
DIST notify-osd-0.9.11.tar.gz 503932 RMD160 42e64584e5ebf87d3527304de9d409f73e2046d8 SHA1 3c9dfaa136065016fa6333d5ed268450fa2e7eea SHA256 6e66402673626de4178a745e95cdf955847828ba20512046f560deb9f9ef7cae
DIST notify-osd-0.9.12.tar.gz 504492 RMD160 e15487d4ef0b549b8b057ef6fa61e26cf475cbc0 SHA1 ea361a3402fbf490b53bc4546cfd998b103475ae SHA256 2246fb299fa3721509c3cabe0790324ad483228cfbc2ca20dae92ff60fa4af76
DIST notify-osd-0.9.20.tar.gz 593793 RMD160 0980cd85532a621aded830303351eb40a6028c63 SHA1 a50983247189cf961f2fa31140377d42e5427a64 SHA256 81102d95c6706f59469dbe4b0f91522fc515ebe4038dff13eb4d5272eacddbc9
+DIST notify-osd-0.9.24.tar.gz 604846 RMD160 6963ec9bdd0514626e5e899f9dc9c939cdb82778 SHA1 0dd092434dfff2fe0b0dd1a34b325e963e8d7eff SHA256 6bec07bca57517f03157b6c18fde5f5a40e35c77c54594dc7920f540f8fd0cc1
EBUILD notify-osd-0.9.11.ebuild 755 RMD160 1814aabfb8d41c0d54f48b2de865fe704a8f9fd4 SHA1 b7ff46dfe7b5e45b9f4b494dc2b4199616012cc8 SHA256 3cf2e51475ee146108c42504f3c2d3a16ace874380d8daf641328ecd7bf7a528
EBUILD notify-osd-0.9.12.ebuild 718 RMD160 642660f6e82676c44484afce88baea45c78a8a40 SHA1 8ff434b46f7adcb902fffdfa62bdfcd10a46d089 SHA256 428e4d0708801b8e62734dad1c99e06f9e9921946eba3c6adc4cf35b184ec7dd
EBUILD notify-osd-0.9.20.ebuild 1085 RMD160 019db8909d93af9c61dc0622b4ab484f3f8622fc SHA1 1b8cdc4cdd05c2268eb6352073cb87ed01924cca SHA256 430ce04bfd407f9b9942291637fc64ddfa5b25863dde87a35c283a1cfd2a2ed5
+EBUILD notify-osd-0.9.24.ebuild 1163 RMD160 7c1732687bc4929bd9a5110d97e6deb271a1c7c1 SHA1 4f67eee5cefc1a1e0189cd504631debb96fbdd52 SHA256 d2eea77bfa121486f980a3e0053e3d48b13bfb5bfc9cdc2f6f707b68eeff9e25
diff --git a/x11-misc/notify-osd/notify-osd-0.9.24.ebuild b/x11-misc/notify-osd/notify-osd-0.9.24.ebuild
new file mode 100644
index 0000000..326811c
--- /dev/null
+++ b/x11-misc/notify-osd/notify-osd-0.9.24.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Canonical's on-screen-display notification agent"
+HOMEPAGE="https://launchpad.net/notify-osd"
+#SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+SRC_URI="http://launchpad.net/${PN}/trunk/ubuntu-9.10/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples mono"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=dev-libs/dbus-glib-0.76
+ >=gnome-base/gconf-2
+ >=x11-libs/gtk+-2.14
+ >=x11-libs/libnotify-0.4.5
+ x11-libs/libwnck
+ !x11-misc/notification-daemon
+ !x11-misc/notification-daemon-xfce
+ !x11-misc/xfce4-notifyd"
+DEPEND="${RDEPEND}
+ examples? ( mono? ( dev-dotnet/notify-sharp ) )
+ >=dev-util/pkgconfig-0.9"
+
+RESTRICT="test"
+
+src_compile() {
+ local myconf
+
+ if use examples ; then
+ if use mono ; then
+ myconf="${myconf} --with-examples=all"
+ else
+ myconf="${myconf} --with-examples=c"
+ fi
+ else
+ myconf="${myconf} --without-examples"
+ fi
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}