summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-08-25 15:13:43 +0200
committerRomain Perier <mrpouet@gentoo.org>2009-08-25 15:13:43 +0200
commitbbe15f8666e6a62f36ebac7375c5c809541a62c3 (patch)
tree415f87406df656e05539574d5e1aca044b8188e0
parentx11-misc/cairo-dock-plugins: Clean-up automatic autotools CFLAGS, and drop -03 (diff)
downloadmrpouet-bbe15f8666e6a62f36ebac7375c5c809541a62c3.tar.gz
mrpouet-bbe15f8666e6a62f36ebac7375c5c809541a62c3.tar.bz2
mrpouet-bbe15f8666e6a62f36ebac7375c5c809541a62c3.zip
x11-misc/cairo-dock: add pkg_postinst() function to notify about a problem with qt4-based applications
-rw-r--r--x11-misc/cairo-dock/Manifest2
-rw-r--r--x11-misc/cairo-dock/cairo-dock-2.0.8.ebuild11
2 files changed, 10 insertions, 3 deletions
diff --git a/x11-misc/cairo-dock/Manifest b/x11-misc/cairo-dock/Manifest
index edcc5ee..0efdf1b 100644
--- a/x11-misc/cairo-dock/Manifest
+++ b/x11-misc/cairo-dock/Manifest
@@ -1,2 +1,2 @@
DIST cairo-dock-2.0.8.tar.bz2 1173653 RMD160 b0aa90c6b7b050005790088b6c54212dd15e8619 SHA1 980879bfbd0944b8e3de8ec6c6fe9b290c5f47fc SHA256 e4c0ddd1d21ae38e6a5c65a6a84ea81ae8b3c80c249980b4e575c327ba61f633
-EBUILD cairo-dock-2.0.8.ebuild 1061 RMD160 a380602dbdb618d722b6a759ae4e2818b939d583 SHA1 2314adfbe554254c993e5457111e3390885a6c7e SHA256 79e8f622a21f1f2034261db11143005d5365bb60159d40b64675b292710fadd7
+EBUILD cairo-dock-2.0.8.ebuild 1546 RMD160 4eaffec758c8b5a298ca7efceb5b5e6c92aa3286 SHA1 89476894a2b248e3f45ad3750daf2e24839f948e SHA256 5cd2257387ce08ad7872049dd5b884a2dcc8fa86059ec74b0e8750016e87929c
diff --git a/x11-misc/cairo-dock/cairo-dock-2.0.8.ebuild b/x11-misc/cairo-dock/cairo-dock-2.0.8.ebuild
index 57f0c4c..011f04d 100644
--- a/x11-misc/cairo-dock/cairo-dock-2.0.8.ebuild
+++ b/x11-misc/cairo-dock/cairo-dock-2.0.8.ebuild
@@ -42,11 +42,18 @@ src_prepare() {
# Fix infinite loop while processing po/Makefile.in
eautoreconf
}
-
src_configure() {
econf $(use_enable glitz) $(use_enable xcomposite xextend)
}
-
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
}
+pkg_postinst() {
+ elog "Cairo-Dock is an app that draws on a RGBA GLX visual."
+ elog "Some users have noticed that if the dock is launched,"
+ elog "severals qt4-based applications could crash, like skype or vlc."
+ elog "If you have this problem, add the following line into your bashrc :"
+ echo
+ elog "alias vlc='export XLIB_SKIP_ARGB_VISUALS=1; vlc; unset XLIB_SKIP_ARGB_VISUALS'"
+ elog "see http://www.qtforum.org/article/26669/qt4-mess-up-the-opengl-context.html for more details."
+}