summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/liblouis/liblouis-2.5.2.ebuild')
-rw-r--r--dev-libs/liblouis/liblouis-2.5.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/liblouis/liblouis-2.5.2.ebuild b/dev-libs/liblouis/liblouis-2.5.2.ebuild
new file mode 100644
index 0000000..aba03e4
--- /dev/null
+++ b/dev-libs/liblouis/liblouis-2.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A Braille translation and back-translation library"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+HOMEPAGE="http://code.google.com/p/liblouis/"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+wide-unicode"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ virtual/pkgconfig"
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ default
+}
+
+src_configure() {
+ econf --disable-static \
+ $(use_enable wide-unicode ucs4)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}