summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/spotify/spotify-0.8.8.323.ebuild')
-rw-r--r--media-sound/spotify/spotify-0.8.8.323.ebuild55
1 files changed, 28 insertions, 27 deletions
diff --git a/media-sound/spotify/spotify-0.8.8.323.ebuild b/media-sound/spotify/spotify-0.8.8.323.ebuild
index cc1a41b..b7da872 100644
--- a/media-sound/spotify/spotify-0.8.8.323.ebuild
+++ b/media-sound/spotify/spotify-0.8.8.323.ebuild
@@ -67,36 +67,37 @@ src_unpack() {
unpack ./data.tar.gz
}
-src_prepare() {
- # link against openssl-1.0.0 as it crashes with 0.9.8
- sed -i \
- -e 's/\(lib\(ssl\|crypto\).so\).0.9.8/\1.1.0.0/g' \
- usr/share/spotify/spotify || die "sed failed"
- # different NSPR / NSS library names for some reason
- sed -i \
- -e 's/\(lib\(nss3\|nssutil3\|smime3\).so\).1d/\1.12/g' \
- -e 's/\(lib\(plc4\|nspr4\).so\).0d\(.\)/\1.9\3\3/g' \
- usr/share/spotify/libcef.so || die "sed failed"
- # Fix desktop entry to launch spotify-dbus.py for GNOME integration
- if use gnome ; then
- sed -i \
- -e 's/spotify \%U/spotify-dbus.py \%U/g' \
- usr/share/applications/spotify.desktop || die "sed failed"
- fi
- #and fix other stuff in the desktop file as well
- sed -i \
- -e 's/x-scheme-handler\/spotify$/x-scheme-handler\/spotify\;/g' \
- -e 's/AudioVideo$/AudioVideo\;/g' \
- usr/share/applications/spotify.desktop || die "sed failed"
-}
+#src_prepare() {
+# # link against openssl-1.0.0 as it crashes with 0.9.8
+# sed -i \
+# -e 's/\(lib\(ssl\|crypto\).so\).0.9.8/\1.1.0.0/g' \
+# usr/share/spotify/spotify || die "sed failed"
+# # different NSPR / NSS library names for some reason
+# sed -i \
+# -e 's/\(lib\(nss3\|nssutil3\|smime3\).so\).1d/\1.12/g' \
+# -e 's/\(lib\(plc4\|nspr4\).so\).0d\(.\)/\1.9\3\3/g' \
+# usr/share/spotify/libcef.so || die "sed failed"
+# # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+# if use gnome ; then
+# sed -i \
+# -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+# usr/share/applications/spotify.desktop || die "sed failed"
+# fi
+# #and fix other stuff in the desktop file as well
+# sed -i \
+# -e 's/x-scheme-handler\/spotify$/x-scheme-handler\/spotify\;/g' \
+# -e 's/AudioVideo$/AudioVideo\;/g' \
+# usr/share/applications/spotify.desktop || die "sed failed"
+#}
src_install() {
+ dodoc opt/spotify/spotify-client/changelog
dodoc usr/share/doc/spotify-client/changelog.Debian.gz
dodoc usr/share/doc/spotify-client/copyright
insinto /usr/share/applications
- doins usr/share/applications/*.desktop
+# doins usr/share/applications/*.desktop
insinto /usr/share/pixmaps
- doins usr/share/pixmaps/*.png
+ doins opt/spotify/spotify-client/Icons/*.png
# install in /opt/spotify
SPOTIFY_HOME=/opt/spotify
@@ -124,9 +125,9 @@ src_install() {
if use pax_kernel; then
#create the headers, reset them to default, then paxmark -m them
- pax-mark C "${ED}"/opt/${PN}/${PN} || die
- pax-mark z "${ED}"/opt/${PN}/${PN} || die
- pax-mark m "${ED}"/opt/${PN}/${PN} || die
+ pax-mark C "${ED}"/opt/${PN}/spotify-client/${PN} || die
+ pax-mark z "${ED}"/opt/${PN}/spotify-client/${PN} || die
+ pax-mark m "${ED}"/opt/${PN}/spotify-client/${PN} || die
eqawarn "You have set USE=pax_kernel meaning that you intendto run"
eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"