summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/soaplib/soaplib-1.0.0.ebuild')
-rw-r--r--dev-python/soaplib/soaplib-1.0.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/soaplib/soaplib-1.0.0.ebuild b/dev-python/soaplib/soaplib-1.0.0.ebuild
new file mode 100644
index 0000000..58742b2
--- /dev/null
+++ b/dev-python/soaplib/soaplib-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+inherit distutils eutils
+
+DESCRIPTION="A simple library for writing soap web services."
+HOMEPAGE="http://wiki.github.com/jkp/soaplib"
+SRC_URI="https://github.com/${PN}/${PN}/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples "
+
+RDEPEND="
+ dev-python/lxml
+ dev-python/pytz
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+"
+
+S="${WORKDIR}/soaplib-soaplib-2801978"
+
+src_install() {
+# DOCS="soaplib_docs.markdown TODO.txt"
+ distutils_src_install
+
+ rm -rf "${ED}$(python_get_sitedir)/tests/"
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.py || die "doins failed"
+ fi
+}
+
+
+src_test() {
+ "$(PYTHON)" setup.py test || die "tests failed"
+}