summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/entrance/entrance-9999.ebuild')
-rw-r--r--x11-misc/entrance/entrance-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-misc/entrance/entrance-9999.ebuild b/x11-misc/entrance/entrance-9999.ebuild
index dab3b81..269eb9c 100644
--- a/x11-misc/entrance/entrance-9999.ebuild
+++ b/x11-misc/entrance/entrance-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-inherit autotools git-2 pam systemd
+inherit autotools eutils git-2 pam
DESCRIPTION="Display-manager based on efl"
HOMEPAGE="http://www.enlightenment.org/"
@@ -24,9 +24,11 @@ RDEPEND="
consolekit? ( sys-auth/consolekit )
pam? ( sys-libs/pam )"
DEPEND="${RDEPEND}
+ !<sys-apps/systemd-192
virtual/pkgconfig"
src_prepare() {
+ epatch "${FILESDIR}"/0001-disable-check-for-systemd.patch
eautoreconf
}
@@ -36,6 +38,8 @@ src_configure() {
$(use_enable ekbd)
$(use_enable grub2)
$(use_enable pam)
+ # only installs unit file for now
+ --enable-systemd
)
econf "${config[@]}"
@@ -45,5 +49,4 @@ src_install() {
default
newpamd "${FILESDIR}"/entrance.pamd entrance
- systemd_dounit "${FILESDIR}"/entrance.service
}