aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergio Durigan Junior <sergiodj@redhat.com>2019-08-21 16:22:45 -0400
committerSergio Durigan Junior <sergiodj@redhat.com>2019-08-23 13:13:18 -0400
commit2d41fa1165c0e28d938ee3bae5c32db371dccf29 (patch)
treef712ad14b44c800d0de74b8da60c0c888fb23db5 /gdb/Makefile.in
parentFix bug in nios2 prologue analysis. (diff)
downloadbinutils-gdb-2d41fa1165c0e28d938ee3bae5c32db371dccf29.tar.gz
binutils-gdb-2d41fa1165c0e28d938ee3bae5c32db371dccf29.tar.bz2
binutils-gdb-2d41fa1165c0e28d938ee3bae5c32db371dccf29.zip
Move gdb-dlfcn.[ch] to gdbsupport/
I need to use 'gdb_dlopen' inside 'gdbsupport/', but it's not yet supported there. This commit moves 'gdb-dlfcn.[ch]' to 'gdbsupport/', which makes it available also on gdbserver. gdb/ChangeLog: 2019-08-23 Sergio Durigan Junior <sergiodj@redhat.com> * configure.ac: Don't check for 'dlfcn.h' (moved to gdbsupport/common.m4). * Makefile.in (COMMON_SFILES): Move 'gdb-dlfcn.c' to 'gdbsupport/'. (HFILES_NO_SRCDIR): Likewise, for 'gdb-dlfcn.h'. * compile/compile-c-support.c: Include 'gdbsupport/gdb-dlfcn.h'. * gdbsupport/common.m4: Check for 'dlfcn.h'. * gdb-dlfcn.c: Move to... * gdbsupport/gdb-dlfcn.c: ... here. * gdb-dlfcn.h: Move to... * gdbsupport/gdb-dlfcn.h: ... here. gdb/gdbserver/ChangeLog: 2019-08-23 Sergio Durigan Junior <sergiodj@redhat.com> * Makefile.in (SFILES): Add 'gdbsupport/gdb-dlfcn.c'. (OBS): Add 'gdbsupport/gdb-dlfcn.o'. * config.in: Regenerate. * configure: Regenerate.
Diffstat (limited to 'gdb/Makefile.in')
-rw-r--r--gdb/Makefile.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/gdb/Makefile.in b/gdb/Makefile.in
index d5d095aae4d..e7e26a44a0c 100644
--- a/gdb/Makefile.in
+++ b/gdb/Makefile.in
@@ -964,6 +964,7 @@ COMMON_SFILES = \
gdbsupport/filestuff.c \
gdbsupport/format.c \
gdbsupport/job-control.c \
+ gdbsupport/gdb-dlfcn.c \
gdbsupport/gdb_tilde_expand.c \
gdbsupport/gdb_vecs.c \
gdbsupport/netstuff.c \
@@ -1028,7 +1029,6 @@ COMMON_SFILES = \
frame-unwind.c \
gcore.c \
gdb_bfd.c \
- gdb-dlfcn.c \
gdb_obstack.c \
gdb_regex.c \
gdb_usleep.c \
@@ -1262,7 +1262,6 @@ HFILES_NO_SRCDIR = \
gcore.h \
gdb_bfd.h \
gdb_curses.h \
- gdb-dlfcn.h \
gdb_expat.h \
gdb_obstack.h \
gdb_proc_service.h \
@@ -1460,6 +1459,7 @@ HFILES_NO_SRCDIR = \
gdbsupport/environ.h \
gdbsupport/fileio.h \
gdbsupport/format.h \
+ gdbsupport/gdb-dlfcn.h \
gdbsupport/gdb_assert.h \
gdbsupport/gdb_tilde_expand.h \
gdbsupport/gdb_locale.h \