aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnulib/update-gnulib.sh')
-rwxr-xr-xgnulib/update-gnulib.sh14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnulib/update-gnulib.sh b/gnulib/update-gnulib.sh
index 0c8357c8880..634676a68d8 100755
--- a/gnulib/update-gnulib.sh
+++ b/gnulib/update-gnulib.sh
@@ -174,7 +174,7 @@ apply_patches "patches/0002-mkostemp-mkostemps-Fix-compilation-error-in-C-mode-o
apply_patches "patches/0003-Fix-glob-c-Coverity-issues.patch"
# Regenerate all necessary files...
-aclocal -Iimport/m4 -I../config &&
+aclocal &&
autoconf &&
autoheader &&
automake
@@ -182,15 +182,3 @@ if [ $? -ne 0 ]; then
echo "Error: Failed to regenerate Makefiles and configure scripts."
exit 1
fi
-
-# Update aclocal-m4-deps.mk
-ACLOCAL_M4_DEPS_FILE=aclocal-m4-deps.mk
-cat > ${ACLOCAL_M4_DEPS_FILE}.tmp <<EOF
-# THIS FILE IS GENERATED. -*- buffer-read-only: t -*- vi :set ro:
-aclocal_m4_deps = \\
-$(find import/m4 -type f -name "*.m4" | LC_COLLATE=C sort | \
- sed 's/^/ /; s/$/ \\/; $s/ \\//g')
-EOF
-
-../move-if-change ${ACLOCAL_M4_DEPS_FILE}.tmp ${ACLOCAL_M4_DEPS_FILE}
-rm -f ${ACLOCAL_M4_DEPS_FILE}.tmp