aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@redhat.com>2019-04-18 11:37:26 +0200
committerGitHub <noreply@github.com>2019-04-18 11:37:26 +0200
commit23bace26ec265557697cf3b578b361c178070cd5 (patch)
tree41d99b73d99a1f8295ed6177113ed7796c8ed784 /setup.py
parentbpo-36071 Add support for Windows ARM32 in ctypes/libffi (GH-12059) (diff)
downloadcpython-23bace26ec265557697cf3b578b361c178070cd5.tar.gz
cpython-23bace26ec265557697cf3b578b361c178070cd5.tar.bz2
cpython-23bace26ec265557697cf3b578b361c178070cd5.zip
bpo-36635: Add _testinternalcapi module (GH-12841)
Add a new _testinternalcapi module to test the internal C API. Move _Py_GetConfigsAsDict() function to the internal C API: _testembed now uses _testinternalcapi to access the function.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index c470719a6a8..3d6404f89ee 100644
--- a/setup.py
+++ b/setup.py
@@ -814,6 +814,10 @@ class PyBuildExt(build_ext):
self.add(Extension('_testcapi', ['_testcapimodule.c'],
depends=['testcapi_long.h']))
+ # Python Internal C API test module
+ self.add(Extension('_testinternalcapi', ['_testinternalcapi.c'],
+ extra_compile_args=['-D Py_BUILD_CORE_MODULE']))
+
# Python PEP-3118 (buffer protocol) test module
self.add(Extension('_testbuffer', ['_testbuffer.c']))