aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@redhat.com>2019-04-23 12:26:33 +0200
committerGitHub <noreply@github.com>2019-04-23 12:26:33 +0200
commit574913479f26b5ff48827861bce68281be01d16e (patch)
tree55f65fb7f0580b50e7b095ff8fa0d6a8b1a77b7b /setup.py
parentuse `const` in graminit.c (GH-12713) (diff)
downloadcpython-574913479f26b5ff48827861bce68281be01d16e.tar.gz
cpython-574913479f26b5ff48827861bce68281be01d16e.tar.bz2
cpython-574913479f26b5ff48827861bce68281be01d16e.zip
bpo-36635, bpo-36696: Fix setup.py on AIX (GH-12922)
xlc compiler doesn't support "-D define" flag only "-Ddefine".
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 3d6404f89ee..58c16e8ba49 100644
--- a/setup.py
+++ b/setup.py
@@ -726,12 +726,12 @@ class PyBuildExt(build_ext):
self.add(Extension("_heapq", ["_heapqmodule.c"]))
# C-optimized pickle replacement
self.add(Extension("_pickle", ["_pickle.c"],
- extra_compile_args=['-D Py_BUILD_CORE_MODULE']))
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE']))
# atexit
self.add(Extension("atexit", ["atexitmodule.c"]))
# _json speedups
self.add(Extension("_json", ["_json.c"],
- extra_compile_args=['-D Py_BUILD_CORE_MODULE']))
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE']))
# profiler (_lsprof is for cProfile.py)
self.add(Extension('_lsprof', ['_lsprof.c', 'rotatingtree.c']))
@@ -816,7 +816,7 @@ class PyBuildExt(build_ext):
# Python Internal C API test module
self.add(Extension('_testinternalcapi', ['_testinternalcapi.c'],
- extra_compile_args=['-D Py_BUILD_CORE_MODULE']))
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE']))
# Python PEP-3118 (buffer protocol) test module
self.add(Extension('_testbuffer', ['_testbuffer.c']))