aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Liebler <stli@linux.ibm.com>2018-12-18 13:57:24 +0100
committerStefan Liebler <stli@linux.ibm.com>2018-12-18 13:57:24 +0100
commitc62534ae524111eae48b2c2adf3f9a2ca90824f5 (patch)
treeda07e010bcc14752b47a8b438daf39b502faf3a9 /sysdeps/s390/wmemchr.c
parentS390: Refactor wcscspn ifunc handling. (diff)
downloadglibc-c62534ae524111eae48b2c2adf3f9a2ca90824f5.tar.gz
glibc-c62534ae524111eae48b2c2adf3f9a2ca90824f5.tar.bz2
glibc-c62534ae524111eae48b2c2adf3f9a2ca90824f5.zip
S390: Refactor wmemchr ifunc handling.
The ifunc handling for wmemchr is adjusted in order to omit ifunc if the minimum architecture level already supports newer CPUs by default. Unfortunately the c ifunc variant can't be omitted at all as it is used by the z13 ifunc variant as fallback if the pointers are not 4-byte aligned. Glibc internal calls will use the "newer" ifunc variant. ChangeLog: * sysdeps/s390/multiarch/Makefile (sysdep_routines): Remove wmemchr variants. * sysdeps/s390/Makefile (sysdep_routines): Add wmemchr variants. * sysdeps/s390/multiarch/ifunc-impl-list.c (__libc_ifunc_impl_list): Refactor ifunc handling for wmemchr. * sysdeps/s390/multiarch/wmemchr-c.c: Move to ... * sysdeps/s390/wmemchr-c.c: ... here and adjust ifunc handling. * sysdeps/s390/multiarch/wmemchr-vx.S: Move to ... * sysdeps/s390/wmemchr-vx.S: ... here and adjust ifunc handling. * sysdeps/s390/multiarch/wmemchr.c: Move to ... * sysdeps/s390/wmemchr.c: ... here and adjust ifunc handling. * sysdeps/s390/ifunc-wmemchr.h: New file.
Diffstat (limited to 'sysdeps/s390/wmemchr.c')
-rw-r--r--sysdeps/s390/wmemchr.c43
1 files changed, 43 insertions, 0 deletions
diff --git a/sysdeps/s390/wmemchr.c b/sysdeps/s390/wmemchr.c
new file mode 100644
index 0000000000..0d2fbb22c6
--- /dev/null
+++ b/sysdeps/s390/wmemchr.c
@@ -0,0 +1,43 @@
+/* Multiple versions of wmemchr.
+ Copyright (C) 2015-2018 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+
+ The GNU C Library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2.1 of the License, or (at your option) any later version.
+
+ The GNU C Library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with the GNU C Library; if not, see
+ <http://www.gnu.org/licenses/>. */
+
+#include <ifunc-wmemchr.h>
+
+#if HAVE_WMEMCHR_IFUNC
+# define wmemchr __redirect_wmemchr
+# define __wmemchr __redirect___wmemchr
+# include <wchar.h>
+# undef wmemchr
+# undef __wmemchr
+# include <ifunc-resolve.h>
+
+# if HAVE_WMEMCHR_C
+extern __typeof (__redirect___wmemchr) WMEMCHR_C attribute_hidden;
+# endif
+
+# if HAVE_WMEMCHR_Z13
+extern __typeof (__redirect___wmemchr) WMEMCHR_Z13 attribute_hidden;
+# endif
+
+s390_libc_ifunc_expr (__redirect___wmemchr, __wmemchr,
+ (HAVE_WMEMCHR_Z13 && (hwcap & HWCAP_S390_VX))
+ ? WMEMCHR_Z13
+ : WMEMCHR_DEFAULT
+ )
+weak_alias (__wmemchr, wmemchr)
+#endif