aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndré Erdmann <dywi@mailerd.de>2012-08-03 17:03:00 +0200
committerAndré Erdmann <dywi@mailerd.de>2012-08-03 17:03:00 +0200
commitf6015209c0aad134c96914a205c15236060fa62e (patch)
treea53f19d0ea9f87ae58caffe2d13d8609bf8dce5a /roverlay-9999.ebuild
parentexclude roverlay.py from setup.py (diff)
downloadR_overlay-f6015209c0aad134c96914a205c15236060fa62e.tar.gz
R_overlay-f6015209c0aad134c96914a205c15236060fa62e.tar.bz2
R_overlay-f6015209c0aad134c96914a205c15236060fa62e.zip
roverlay live ebuild
The ebuild is *highly* experimental (particularly the example config file destination, /usr/share/roverlay-9999) and should be regarded as first attempt.
Diffstat (limited to 'roverlay-9999.ebuild')
-rw-r--r--roverlay-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/roverlay-9999.ebuild b/roverlay-9999.ebuild
new file mode 100644
index 0000000..fdcdc00
--- /dev/null
+++ b/roverlay-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+# python3_1 is probably supported, too (<2.7 is not)
+PYTHON_COMPAT="python2_7 python3_2"
+
+inherit base python-distutils-ng git-2
+
+EGIT_REPO_URI='git://git.overlays.gentoo.org/proj/R_overlay.git'
+
+DESCRIPTION="Automatically generated overlay of R packages (SoC2012)"
+HOMEPAGE="http://git.overlays.gentoo.org/gitweb/?p=proj/R_overlay.git;a=summary"
+SRC_URI=""
+
+LICENSE="GPL-2" #?
+SLOT="0"
+IUSE=""
+
+KEYWORDS=""
+
+DEPEND=""
+RDEPEND="${DEPEND:-}
+ dev-python/argparse
+"
+
+python_prepare_all() {
+ base_src_prepare
+}
+
+python_install_all() {
+ insinto "/usr/share/${PN}"
+ doins config/description_fields.conf config/R-overlay.conf repo.list
+ if [[ -e "R-overlay.conf.install" ]]; then
+ newins R-overlay.conf.install R-overlay.conf.quickstart
+ else
+ newins R-overlay.conf R-overlay.conf.quickstart
+ fi
+
+ doman man/?*.?*
+
+ newbin roverlay.py roverlay
+}