summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-09-17 23:27:47 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-09-17 23:28:33 -0500
commit0ca11c8aa1a8c8e0b95987f19b778ecdce4c8c61 (patch)
tree18017304e0738c1c1e17839bfab6db02394ebca7
parentRelax checks on KEEPDIR when directories are mounted fs (diff)
downloadbaselayout-0ca11c8aa1a8c8e0b95987f19b778ecdce4c8c61.tar.gz
baselayout-0ca11c8aa1a8c8e0b95987f19b778ecdce4c8c61.tar.bz2
baselayout-0ca11c8aa1a8c8e0b95987f19b778ecdce4c8c61.zip
silence message about ignoring the touch failure
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 230acbc5..493c824b 100644
--- a/Makefile
+++ b/Makefile
@@ -77,7 +77,7 @@ layout-dirs:
for x in $(KEEP_DIRS) ; do \
test -e $(DESTDIR)$$x/.keep && continue ; \
$(INSTALL_DIR) $(DESTDIR)$$x ; \
- touch $(DESTDIR)$$x/.keep || echo "ignoring touch failure; mounted fs?" ; \
+ touch $(DESTDIR)$$x/.keep || true; \
done
layout-BSD: layout-dirs