summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2014-09-20 20:17:50 +0200
committerSebastian Pipping <sebastian@pipping.org>2014-09-20 20:39:54 +0200
commit7d920494dd39bcb954789111b5d10a1a29a1b388 (patch)
tree00e5f3e30f4b458be859d41a58f3502c57be503c /gnome-extra/gnome-paint/files
parentgames-board/gambit: 0_p31 (diff)
downloadbetagarden-7d920494dd39bcb954789111b5d10a1a29a1b388.tar.gz
betagarden-7d920494dd39bcb954789111b5d10a1a29a1b388.tar.bz2
betagarden-7d920494dd39bcb954789111b5d10a1a29a1b388.zip
gnome-extra/gnome-paint: 0.4.0-r1
Diffstat (limited to 'gnome-extra/gnome-paint/files')
-rw-r--r--gnome-extra/gnome-paint/files/gnome-paint-0.4.0-crash-get_gtk_image.patch38
-rw-r--r--gnome-extra/gnome-paint/files/gnome-paint-0.4.0-libm.patch28
2 files changed, 66 insertions, 0 deletions
diff --git a/gnome-extra/gnome-paint/files/gnome-paint-0.4.0-crash-get_gtk_image.patch b/gnome-extra/gnome-paint/files/gnome-paint-0.4.0-crash-get_gtk_image.patch
new file mode 100644
index 0000000..8fe68b2
--- /dev/null
+++ b/gnome-extra/gnome-paint/files/gnome-paint-0.4.0-crash-get_gtk_image.patch
@@ -0,0 +1,38 @@
+From 80957a66306bc68af9119808f81b8e42171a39e4 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 20 Sep 2014 20:31:39 +0200
+Subject: [PATCH] Fix crash in get_gtk_image
+
+Based on https://bazaar.launchpad.net/~andrewwang43/gnome-paint/nosegfault/diff/84
+---
+ src/toolbar.c | 12 +++++-------
+ 1 file changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/src/toolbar.c b/src/toolbar.c
+index 1c5ba03..ad5cffd 100644
+--- a/src/toolbar.c
++++ b/src/toolbar.c
+@@ -497,15 +497,13 @@ on_brush11_realize (GtkObject *object, gpointer user_data)
+ static GtkWidget *
+ get_gtk_image ( GtkWidget *widget, gchar** xpm )
+ {
+- GdkPixmap *gdkpixmap = NULL;
+- GdkBitmap *mask = NULL;
++ GdkPixbuf *gdkpixbuf = NULL;
+ GtkWidget *gtkimage = NULL;
+- gdkpixmap = gdk_pixmap_create_from_xpm_d(widget->window, &mask, NULL, xpm);
+- g_assert ( gdkpixmap );
+- gtkimage = gtk_image_new_from_pixmap(gdkpixmap, mask);
++ gdkpixbuf = gdk_pixbuf_new_from_xpm_data(xpm);
++ g_assert ( gdkpixbuf );
++ gtkimage = gtk_image_new_from_pixbuf(gdkpixbuf);
+ g_assert ( gtkimage );
+- g_object_unref ( G_OBJECT(gdkpixmap) );
+- g_object_unref ( G_OBJECT(mask) );
++ g_object_unref ( G_OBJECT(gdkpixbuf) );
+ gtk_widget_show(gtkimage);
+ return gtkimage;
+ }
+--
+2.1.0
+
diff --git a/gnome-extra/gnome-paint/files/gnome-paint-0.4.0-libm.patch b/gnome-extra/gnome-paint/files/gnome-paint-0.4.0-libm.patch
new file mode 100644
index 0000000..c8388f8
--- /dev/null
+++ b/gnome-extra/gnome-paint/files/gnome-paint-0.4.0-libm.patch
@@ -0,0 +1,28 @@
+From ff61205fc363473d8b029dd9e822a0bc0e6712b8 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 20 Sep 2014 20:10:42 +0200
+Subject: [PATCH] Add missing -lm to fix link error
+
+[..]/bin/ld: gnome_paint-cv_paintbrush_tool.o: undefined reference to symbol 'sqrt@@GLIBC_2.2.5'
+/lib64/libm.so.6: error adding symbols: DSO missing from command line
+collect2: error: ld returned 1 exit status
+---
+ src/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 2bea3b4..852ae55 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -87,7 +87,7 @@ gnome_paint_LDFLAGS = \
+ -Wl,--export-dynamic
+
+ gnome_paint_LDADD = \
+- $(GNOME_PAINT_LIBS) -lX11
++ $(GNOME_PAINT_LIBS) -lX11 -lm
+
+ SUBDIRS = \
+ pixmaps
+--
+2.1.0
+