aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Thibodeau <kyron@neuralbs.com>2008-07-18 09:10:34 -0400
committerEric Thibodeau <kyron@neuralbs.com>2008-07-18 09:10:34 -0400
commit8e423982134cdf1cc9c15972a896328a885287b1 (patch)
tree20406147be2c92fefb5f1ac5847887a1142cfa3d /overlay/sys-cluster/beowulf-head/beowulf-head-0.1.ebuild
parentCleanup and nfs4 to nonfs4 USE flag change (diff)
downloadclustering-livecd-8e423982134cdf1cc9c15972a896328a885287b1.tar.gz
clustering-livecd-8e423982134cdf1cc9c15972a896328a885287b1.tar.bz2
clustering-livecd-8e423982134cdf1cc9c15972a896328a885287b1.zip
Switch to AuFS, USE nonfs4
AuFS module usage imlpies we're switching back to mainstream gentoo-sources nonfs4 already existed and is used by nfs-utils...we'll tag along
Diffstat (limited to 'overlay/sys-cluster/beowulf-head/beowulf-head-0.1.ebuild')
-rw-r--r--overlay/sys-cluster/beowulf-head/beowulf-head-0.1.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/overlay/sys-cluster/beowulf-head/beowulf-head-0.1.ebuild b/overlay/sys-cluster/beowulf-head/beowulf-head-0.1.ebuild
index 1d4507e..a24b77f 100644
--- a/overlay/sys-cluster/beowulf-head/beowulf-head-0.1.ebuild
+++ b/overlay/sys-cluster/beowulf-head/beowulf-head-0.1.ebuild
@@ -9,7 +9,7 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~x86"
-IUSE="autofs nfs4"
+IUSE="autofs nonfsv4"
DEPEND=""
RDEPEND="net-nds/ldap-auth
@@ -96,15 +96,16 @@ pxe_conf()
mkdir -p ${TFTPROOT}/pxelinux.cfg
cat > ${TFTPROOT}/pxelinux.cfg/default <<-EOF
- prompt 1
- timeout 50
- say Press F1 for boot profiles, default is $PROFNAME in 5 seconds...
+ #prompt 1
+ #timeout 50
+ #say Press F1 for boot profiles, default is $PROFNAME in 5 seconds...
F1 BootProfiles
default $PROFNAME
label $PROFNAME
kernel ${BOOTPATH}/kernel
- append ip=dhcp nfsroot=${CLUSTER_ETH_IP}:${NFSROOT},hard,intr init=/boot/stateless.sh
+ #important: AuFS only supports NFSv3
+ append ip=dhcp nfsroot=${CLUSTER_ETH_IP}:${NFSROOT},hard,intr,nfsvers=3 init=/boot/stateless.sh unionmod=aufs
label local
localboot 0
@@ -133,22 +134,22 @@ nfs_root_conf()
# Yes, this could be looped on RO and RW...but that wouldn't be more redable
for I in $ROEXPORTS
do
- if use nfs4 ; then
+ if use nonfs4 ; then
+ echo "${I} $NETADDR/$SUBNET(ro,$NFSEPORTOPTS)" >> ${ROOT}/etc/exports
+ else
mkdir -p ${NFSROOT}/${I}
mount -o bind ${I} ${NFSROOT}/${I}
- else
- echo "${I} $NETADDR/$SUBNET(ro,$NFSEPORTOPTS)" >> ${ROOT}/etc/exports
fi
use autofs && echo "${I/\/} -ro,$NFSMOUNTOPTS $CLUSTER_ETH_Ir:${I}" >> ${NFSROOT}/etc/autofs/auto.nfs
done
for I in $RWEXPORTS
do
- if use nfs4 ; then
+ if use nonfs4 ; then
+ echo "${I} $NETADDR/$SUBNET(rw,$NFSEPORTOPTS)" >> ${ROOT}/etc/exports
+ else
mkdir -p ${NFSROOT}/${I}
mount -o bind ${I} ${NFSROOT}/${I}
- else
- echo "${I} $NETADDR/$SUBNET(rw,$NFSEPORTOPTS)" >> ${ROOT}/etc/exports
fi
use autofs && echo "${I/\/} -ro,$NFSMOUNTOPTS $CLUSTER_ETH_Ir:${I}" >> ${NFSROOT}/etc/autofs/auto.nfs
done