aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index d022a32..c4bb713 100644
--- a/Makefile
+++ b/Makefile
@@ -60,10 +60,12 @@ documents.js: bin/build_search_documents.py $(XMLS)
xsltproc --param offline "$(OFFLINE)" devbook.xsl $< > $@
eclass-reference/text.xml:
- @echo "*** Warning: No eclass documentation found." >&2
- @echo "Install app-doc/eclass-manpages and" >&2
- @echo "run bin/gen-eclass-html.sh before calling make." >&2
- @echo "Creating a placeholder index as fallback." >&2
+ @if [[ -z $${EBUILD_PHASE} ]]; then \
+ echo "*** Warning: No eclass documentation found." >&2; \
+ echo "Install app-doc/eclass-manpages and" >&2; \
+ echo "run bin/gen-eclass-html.sh before calling make." >&2; \
+ echo "Creating a placeholder index as fallback." >&2; \
+ fi
bin/gen-eclass-html.sh -n
appendices/todo-list/index.html: $(XMLS)