aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-02-13 13:49:28 -0500
committerAnthony G. Basile <blueness@gentoo.org>2014-02-13 13:49:28 -0500
commit84ebf842cb9065b6f75d3117c3e73e90bb838472 (patch)
treebc95add72c1d9e7d65f6ccf842ab928e0df41c3d
parentmisc/install-xattr: remove the .c in the directory name (diff)
downloadelfix-84ebf842cb9065b6f75d3117c3e73e90bb838472.tar.gz
elfix-84ebf842cb9065b6f75d3117c3e73e90bb838472.tar.bz2
elfix-84ebf842cb9065b6f75d3117c3e73e90bb838472.zip
misc/install-xattr: switch to simple Makefile
-rw-r--r--misc/install-xattr/.gitignore1
-rw-r--r--misc/install-xattr/ChangeLog11
-rw-r--r--misc/install-xattr/Makefile22
-rw-r--r--misc/install-xattr/Makefile.am16
-rwxr-xr-xmisc/install-xattr/autogen.sh6
-rwxr-xr-xmisc/install-xattr/checkcopyattrs.sh3
-rw-r--r--misc/install-xattr/configure.ac30
7 files changed, 37 insertions, 52 deletions
diff --git a/misc/install-xattr/.gitignore b/misc/install-xattr/.gitignore
index a0bcfaa..670a765 100644
--- a/misc/install-xattr/.gitignore
+++ b/misc/install-xattr/.gitignore
@@ -12,3 +12,4 @@ install-xattr
x
y
z
+!Makefile
diff --git a/misc/install-xattr/ChangeLog b/misc/install-xattr/ChangeLog
new file mode 100644
index 0000000..13752a3
--- /dev/null
+++ b/misc/install-xattr/ChangeLog
@@ -0,0 +1,11 @@
+Okay we'll document changes here. This is a small project, so we don't
+have to be very formal.
+
+2014-02-13
+
+ * Release version 0.1. For discussion leading up to this release,
+ see https://bugs.gentoo.org/show_bug.cgi?id=465000.
+
+THANKS
+ * Mike Frysinger <vapier@gentoo.org> for your relentless attention.
+ * Greg Turner <gmturner007@ameritech.net> for testing and fixing bugs.
diff --git a/misc/install-xattr/Makefile b/misc/install-xattr/Makefile
new file mode 100644
index 0000000..bbc2cf1
--- /dev/null
+++ b/misc/install-xattr/Makefile
@@ -0,0 +1,22 @@
+CFLAGS ?= -O2 -pipe -g
+CFLAGS += -Wall
+PWD = $$(pwd)
+
+all: install-xattr
+
+install-xattr: install-xattr.c
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $< $(LDLIBS)
+
+PREFIX = /usr
+BINDIR = $(PREFIX)/bin
+install: xattr-install
+ install -m 755 -D install-xattr $(DESTDIR)$(BINDIR)/install-xattr
+
+check: checkcopyattrs.sh install-xattr
+ $(PWD)/checkcopyattrs.sh
+ rm -rf a b c d e f g x y z backup-a* mode-a target-a target-install-xattr
+
+clean:
+ rm -f *.o *~ install-xattr
+
+.PHONY: all check clean install
diff --git a/misc/install-xattr/Makefile.am b/misc/install-xattr/Makefile.am
deleted file mode 100644
index d2ba4d7..0000000
--- a/misc/install-xattr/Makefile.am
+++ /dev/null
@@ -1,16 +0,0 @@
-CFLAGS=
-noinst_PROGRAMS = install-xattr
-install_xattr_SOURCES = install-xattr.c
-install_xattr_CFLAGS = -ggdb -Wall -O3
-
-check_SCRIPTS = checkcopyattrs
-TEST = $(check_SCRIPTS)
-
-checkcopyattrs:
- $(srcdir)/checkcopyattrs.sh
-
-EXTRA_DIST = checkcopyattrs.sh
-CLEANFILES = a b c x y z d/* e/* f/*
-
-clean-local:
- -rm -rf d e f g backup* mode* target*
diff --git a/misc/install-xattr/autogen.sh b/misc/install-xattr/autogen.sh
deleted file mode 100755
index 3888ff3..0000000
--- a/misc/install-xattr/autogen.sh
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-aclocal && \
-autoheader && \
-autoconf && \
-automake --add-missing --copy
diff --git a/misc/install-xattr/checkcopyattrs.sh b/misc/install-xattr/checkcopyattrs.sh
index 210a21c..2e8f30f 100755
--- a/misc/install-xattr/checkcopyattrs.sh
+++ b/misc/install-xattr/checkcopyattrs.sh
@@ -76,3 +76,6 @@ setfattr -n user.pax.flags -v "r" c
#
# -Z, --context=CONTEXT
# set SELinux security context of files and directories
+
+# Okay, let's clean up after ourselves
+rm -rf a b c d e f g x y z backup-a* mode-a target-a target-install-xattr
diff --git a/misc/install-xattr/configure.ac b/misc/install-xattr/configure.ac
deleted file mode 100644
index aca8b1f..0000000
--- a/misc/install-xattr/configure.ac
+++ /dev/null
@@ -1,30 +0,0 @@
-# -*- Autoconf -*-
-# Process this file with autoconf to produce a configure script.
-
-AC_PREREQ([2.69])
-AC_INIT([install-xattr],[1])
-AC_CONFIG_SRCDIR([install-xattr.c])
-AC_CONFIG_HEADERS([config.h])
-
-AM_INIT_AUTOMAKE([1.13 foreign])
-
-# Checks for programs.
-AC_PROG_CC
-AC_PROG_INSTALL
-
-# Checks for libraries.
-
-# Checks for header files.
-AC_CHECK_HEADERS([stdlib.h string.h unistd.h])
-
-# Checks for typedefs, structures, and compiler characteristics.
-AC_TYPE_SIZE_T
-AC_TYPE_SSIZE_T
-
-# Checks for library functions.
-AC_FUNC_FORK
-AC_FUNC_MALLOC
-AC_CHECK_FUNCS([memset realpath strdup])
-
-AC_CONFIG_FILES([Makefile])
-AC_OUTPUT