aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <basile@opensource.dyc.edu>2011-04-12 17:19:38 -0400
committerAnthony G. Basile <basile@opensource.dyc.edu>2011-04-12 17:19:38 -0400
commit88d7d9fffe0f24375a95b57da8788ed02dc5c275 (patch)
tree11f6f8fe9c8596f6d8f728337035e454be61c699 /tests/Makefile.am
parentAdded: test_asm.c test_bad.asm to test RWX in asm (diff)
downloadelfix-88d7d9fffe0f24375a95b57da8788ed02dc5c275.tar.gz
elfix-88d7d9fffe0f24375a95b57da8788ed02dc5c275.tar.bz2
elfix-88d7d9fffe0f24375a95b57da8788ed02dc5c275.zip
Added autotool build system
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..50f6db4
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,9 @@
+bin_PROGRAMS = good
+good_SOURCES = good.c
+
+test-bad.o: test-bad.asm
+ yasm -f elf -m amd64 $<
+
+bad.o: bad.c
+
+bad: bad.o test-bad.o