summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--scripts/package.keywords.livecvs1
-rw-r--r--scripts/package.keywords.snapshots1
-rw-r--r--x11-misc/shellementary/Manifest2
-rw-r--r--x11-misc/shellementary/metadata.xml8
-rw-r--r--x11-misc/shellementary/shellementary-9999.ebuild29
5 files changed, 41 insertions, 0 deletions
diff --git a/scripts/package.keywords.livecvs b/scripts/package.keywords.livecvs
index 5a13f0f..199f53f 100644
--- a/scripts/package.keywords.livecvs
+++ b/scripts/package.keywords.livecvs
@@ -56,6 +56,7 @@ x11-misc/entrance * ~* **
x11-misc/eosd * ~* **
x11-misc/estickies * ~* **
x11-misc/expedite * ~* **
+x11-misc/shellementary * ~* **
x11-plugins/e_modules * ~* **
x11-plugins/e_modules-alarm * ~* **
x11-plugins/e_modules-bling * ~* **
diff --git a/scripts/package.keywords.snapshots b/scripts/package.keywords.snapshots
index 13688d5..aeb428c 100644
--- a/scripts/package.keywords.snapshots
+++ b/scripts/package.keywords.snapshots
@@ -56,6 +56,7 @@ x11-misc/entrance ~*
x11-misc/eosd ~*
x11-misc/estickies ~*
x11-misc/expedite ~*
+x11-misc/shellementary ~*
x11-plugins/e_modules ~*
x11-plugins/e_modules-alarm ~*
x11-plugins/e_modules-bling ~*
diff --git a/x11-misc/shellementary/Manifest b/x11-misc/shellementary/Manifest
new file mode 100644
index 0000000..e1e21c1
--- /dev/null
+++ b/x11-misc/shellementary/Manifest
@@ -0,0 +1,2 @@
+EBUILD shellementary-9999.ebuild 634 RMD160 99bd1a0cc57e7c70cb9a6bb035dfbdc0d19d9856 SHA1 b4d0c7d22add87add8569b8ec2b23786e9431a6a SHA256 b59e57bf24dc6cee7ae29996579592e81718fd2b8ffdcd14f422bd55b35091f1
+MISC metadata.xml 228 RMD160 1890a2965ed780e661e20adcfc4f4cce5f7ca8e9 SHA1 777d2a3ad7f7075c7e75fa5055f3941440e4e875 SHA256 42ea435327140212f3beb05aafebad5053cbad84532f9bb78987de8540c6459a
diff --git a/x11-misc/shellementary/metadata.xml b/x11-misc/shellementary/metadata.xml
new file mode 100644
index 0000000..832c5fc
--- /dev/null
+++ b/x11-misc/shellementary/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>enlightenment@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-misc/shellementary/shellementary-9999.ebuild b/x11-misc/shellementary/shellementary-9999.ebuild
new file mode 100644
index 0000000..36e8989
--- /dev/null
+++ b/x11-misc/shellementary/shellementary-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_PYTHON="2.4"
+ESVN_SUB_PROJECT="PROTO"
+inherit enlightenment python distutils
+
+DESCRIPTION="Tool to display Elementary dialogs from the command line and shell scripts"
+
+RDEPEND=">=x11-libs/ecore-9999
+ >=dev-python/python-evas-9999
+ >=x11-libs/elementary-9999
+ >=media-libs/edje-9999"
+
+src_unpack() {
+ enlightenment_src_unpack
+}
+
+src_compile() {
+ #distutils_src_compile
+ ${python} setup.py build --prefix="${T}/usr"
+
+}
+
+src_install() {
+ #distutils_src_install
+ ${python} setup.py install --prefix="${D}/usr"
+}