diff options
author | Michael Orlitzky <mjo@gentoo.org> | 2017-07-26 11:53:05 -0400 |
---|---|---|
committer | Michael Orlitzky <mjo@gentoo.org> | 2017-07-26 11:53:05 -0400 |
commit | 24b77433ba7a83847fda5a75663bf281a0b87c2a (patch) | |
tree | 814b764ab97b1c96ede5bc798dc17e5648aca142 | |
parent | Install the php-fpm init scripts conditional on --enable-fpm. (diff) | |
download | eselect-php-24b77433ba7a83847fda5a75663bf281a0b87c2a.tar.gz eselect-php-24b77433ba7a83847fda5a75663bf281a0b87c2a.tar.bz2 eselect-php-24b77433ba7a83847fda5a75663bf281a0b87c2a.zip |
Use "init.d" and "conf.d" subdirectories of "openrc".
OpenRC's init and conf files need to be named the same, and so we hit
problems trying to store them both in the "openrc" directory. This
commit puts the conf file in a "conf.d" subdirectory and the init
script in an "init.d" subdirectory.
-rw-r--r-- | .gitignore | 4 | ||||
-rw-r--r-- | Makefile.am | 8 | ||||
-rw-r--r-- | configure.ac | 2 | ||||
-rw-r--r-- | openrc/conf.d/php-fpm (renamed from openrc/php-fpm.conf) | 0 | ||||
-rw-r--r-- | openrc/init.d/php-fpm.in.in (renamed from openrc/php-fpm.in.in) | 0 |
5 files changed, 7 insertions, 7 deletions
@@ -6,8 +6,8 @@ autom4te.cache/ config.log config.status configure -openrc/php-fpm -openrc/php-fpm.in +openrc/init.d/php-fpm +openrc/init.d/php-fpm.in install-sh missing src/php.eselect diff --git a/Makefile.am b/Makefile.am index 08359dc..1d3122a 100644 --- a/Makefile.am +++ b/Makefile.am @@ -2,7 +2,7 @@ eselectdir = $(datadir)/eselect/modules nodist_eselect_DATA = $(srcdir)/src/php.eselect # Without EXTRA_DIST, these files don't wind up in the tarball. -EXTRA_DIST = $(srcdir)/src/70_mod_php.conf.in openrc/*.* +EXTRA_DIST = $(srcdir)/src/70_mod_php.conf.in openrc if APACHE2 # Without these set, we won't try to install the conf file. @@ -13,10 +13,10 @@ endif if FPM # Same as the APACHE2 conditional. initdir = $(sysconfdir)/init.d - nodist_init_SCRIPTS = $(srcdir)/openrc/php-fpm + nodist_init_SCRIPTS = $(srcdir)/openrc/init.d/php-fpm confdir = $(sysconfdir)/conf.d - nodist_conf_DATA = $(srcdir)/openrc/php-fpm.conf + nodist_conf_DATA = $(srcdir)/openrc/conf.d/php-fpm endif # The next few rules allow us to replace bindir, libdir, etc. @@ -37,4 +37,4 @@ $(nodist_eselect_DATA) $(nodist_apacheconf_DATA) $(nodist_init_SCRIPTS): Makefil $(srcdir)/src/php.eselect: $(srcdir)/src/php.eselect.in $(srcdir)/src/70_mod_php.conf: $(srcdir)/src/70_mod_php.conf.in -$(srcdir)/openrc/php-fpm: $(srcdir)/openrc/php-fpm.in +$(srcdir)/openrc/init.d/php-fpm: $(srcdir)/openrc/init.d/php-fpm.in diff --git a/configure.ac b/configure.ac index 02aeaf2..a55baf8 100644 --- a/configure.ac +++ b/configure.ac @@ -41,6 +41,6 @@ AC_ARG_WITH(piddir, AC_HELP_STRING([--with-piddir=DIR], AC_SUBST(piddir) # List of output files. -AC_CONFIG_FILES([Makefile src/php.eselect.in openrc/php-fpm.in]) +AC_CONFIG_FILES([Makefile src/php.eselect.in openrc/init.d/php-fpm.in]) AC_OUTPUT diff --git a/openrc/php-fpm.conf b/openrc/conf.d/php-fpm index b3efdbf..b3efdbf 100644 --- a/openrc/php-fpm.conf +++ b/openrc/conf.d/php-fpm diff --git a/openrc/php-fpm.in.in b/openrc/init.d/php-fpm.in.in index 2eaa2c3..2eaa2c3 100644 --- a/openrc/php-fpm.in.in +++ b/openrc/init.d/php-fpm.in.in |