aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2009-12-24 04:52:44 -0200
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2009-12-24 04:52:44 -0200
commit7fbd53d3d30299f1d72f69e775abfc74465b52e4 (patch)
tree3ec33da82f6b76ddfcc8e5bef8345d350a0ddc81 /ebuilds
parentchanged version (diff)
downloadg-octave-7fbd53d3d30299f1d72f69e775abfc74465b52e4.tar.gz
g-octave-7fbd53d3d30299f1d72f69e775abfc74465b52e4.tar.bz2
g-octave-7fbd53d3d30299f1d72f69e775abfc74465b52e4.zip
added ebuilds/g-octave-0.1_rc1.ebuild
Diffstat (limited to 'ebuilds')
-rw-r--r--ebuilds/g-octave-0.1_rc1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/ebuilds/g-octave-0.1_rc1.ebuild b/ebuilds/g-octave-0.1_rc1.ebuild
new file mode 100644
index 0000000..e11824e
--- /dev/null
+++ b/ebuilds/g-octave-0.1_rc1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit distutils
+
+MY_PV=${PV/_rc/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="A tool that generates and installs ebuilds for Octave-Forge"
+HOMEPAGE="http://bitbucket.org/rafaelmartins/g-octave/"
+SRC_URI="http://bitbucket.org/rafaelmartins/${PN}/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="colors"
+
+DEPEND="<dev-lang/python-3"
+RDEPEND="${DEPEND}
+ sys-apps/portage
+ dev-python/simplejson
+ colors? ( dev-python/pycolors )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ if ! use colors; then
+ sed -i -e 's/from colors .*/raise/' scripts/g-octave \
+ || die 'sed failed.'
+ fi
+}