aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e7f08a3..d18a3f2 100644
--- a/Makefile
+++ b/Makefile
@@ -28,8 +28,12 @@ clean:
rm -f $(EXTRA_DIST)
check-git-repository:
+ifneq ($(UNCLEAN),1)
git diff --quiet || { echo 'STOP, you have uncommitted changes in the working directory' ; false ; }
git diff --cached --quiet || { echo 'STOP, you have uncommitted changes in the index' ; false ; }
+else
+ @true
+endif
dist: verify-doc check-git-repository distclean $(EXTRA_DIST)
mkdir "$(distdir)"