aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index c771738..c3e83c5 100644
--- a/meson.build
+++ b/meson.build
@@ -39,12 +39,8 @@ endif
subdir('bin')
subdir('pym')
-test(
- 'python-unittest',
- py,
- args : ['-m', 'unittest', 'discover', meson.current_source_dir() / 'pym'],
- timeout : 0
-)
+pytest = find_program('pytest')
+test('pytest', pytest, args : ['-v', meson.current_source_dir() / 'pym'])
if get_option('code-only')
subdir_done()