summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/glib/glib-2.9999.ebuild')
-rw-r--r--dev-libs/glib/glib-2.9999.ebuild88
1 files changed, 55 insertions, 33 deletions
diff --git a/dev-libs/glib/glib-2.9999.ebuild b/dev-libs/glib/glib-2.9999.ebuild
index 515be5a..44c70d4 100644
--- a/dev-libs/glib/glib-2.9999.ebuild
+++ b/dev-libs/glib/glib-2.9999.ebuild
@@ -1,31 +1,59 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.20.2.ebuild,v 1.2 2009/05/18 21:37:06 eva Exp $
-inherit eutils flag-o-matic gnome2-live
+EAPI="2"
+
+inherit libtool eutils flag-o-matic gnome2-live
DESCRIPTION="The GLib library of C routines"
HOMEPAGE="http://www.gtk.org/"
+SRC_URI=""
LICENSE="LGPL-2"
SLOT="2"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="debug doc fam hardened selinux xattr"
RDEPEND="virtual/libc
- virtual/libiconv
- xattr? ( sys-apps/attr )
- fam? ( virtual/fam )"
+ virtual/libiconv
+ xattr? ( sys-apps/attr )
+ fam? ( virtual/fam )"
DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.16
- >=sys-devel/gettext-0.11
- doc? (
- >=dev-libs/libxslt-1.0
- >=dev-util/gtk-doc-1.8
- ~app-text/docbook-xml-dtd-4.1.2
- )"
-
-src_compile() {
+ >=dev-util/pkgconfig-0.16
+ >=sys-devel/gettext-0.11
+ doc? (
+ >=dev-libs/libxslt-1.0
+ >=dev-util/gtk-doc-1.11
+ ~app-text/docbook-xml-dtd-4.1.2 )"
+
+src_prepare() {
+ if use ppc64 && use hardened ; then
+ replace-flags -O[2-3] -O1
+ epatch "${FILESDIR}/glib-2.6.3-testglib-ssp.patch"
+ fi
+
+ if use ia64 ; then
+ # Only apply for < 4.1
+ local major=$(gcc-major-version)
+ local minor=$(gcc-minor-version)
+ if (( major < 4 || ( major == 4 && minor == 0 ) )); then
+ epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
+ fi
+ fi
+
+ # Don't fail gio tests when ran without userpriv, upstream bug 552912
+ # This is only a temporary workaround, remove as soon as possible
+ epatch "${FILESDIR}/${PN}-2.18.1-workaround-gio-test-failure-without-userpriv.patch"
+
+ # Fix gmodule issues on fbsd; bug #184301
+ epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
+
+ # No PATCHES use because of convoluted logic
+ gnome2-live_src_prepare
+}
+
+src_configure() {
local myconf
epunt_cxx
@@ -36,7 +64,8 @@ src_compile() {
# -- compnerd (3/27/06)
use debug && myconf="--enable-debug"
- # always build static libs, see #153807
+ # Always build static libs, see #153807
+ # Always use internal libpcre, bug #254659
econf ${myconf} \
$(use_enable xattr) \
$(use_enable doc man) \
@@ -44,21 +73,9 @@ src_compile() {
$(use_enable fam) \
$(use_enable selinux) \
--enable-static \
- --with-threads=posix || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_test() {
- make -C tests
- make -C glib/tests
- make -C gobject/tests
- make -C gio/tests
- make test
- make -C tests test
- make -C glib/tests test
- make -C gobject/tests test
- make -C gio/tests test
+ --enable-regex \
+ --with-pcre=internal \
+ --with-threads=posix
}
src_install() {
@@ -67,5 +84,10 @@ src_install() {
# Do not install charset.alias even if generated, leave it to libiconv
rm -f "${D}/usr/lib/charset.alias"
- dodoc AUTHORS ChangeLog* NEWS* README
+ dodoc AUTHORS ChangeLog* NEWS* README || die "dodoc failed"
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ emake check || die "tests failed"
}