summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-09-25 01:47:39 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-09-25 01:47:39 -0400
commit14a421235fa9b22ebe7aafce757141f0394309ce (patch)
treefd8c237fed369c6a7009ff894ac047cc20738316 /dev-libs/gdl/gdl-9999.ebuild
parentgnome-extra/gnome-color-manager: [QA] Remove unused scrollkeeper (diff)
downloadgnome-14a421235fa9b22ebe7aafce757141f0394309ce.tar.gz
gnome-14a421235fa9b22ebe7aafce757141f0394309ce.tar.bz2
gnome-14a421235fa9b22ebe7aafce757141f0394309ce.zip
dev-libs/gdl: add 3.5.91 and live ebuild
Diffstat (limited to 'dev-libs/gdl/gdl-9999.ebuild')
-rw-r--r--dev-libs/gdl/gdl-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/gdl/gdl-9999.ebuild b/dev-libs/gdl/gdl-9999.ebuild
new file mode 100644
index 00000000..9b54b14a
--- /dev/null
+++ b/dev-libs/gdl/gdl-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="The Gnome Devtool Libraries"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="3"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+fi
+IUSE="doc +introspection"
+
+RDEPEND="dev-libs/glib:2
+ >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=dev-libs/libxml2-2.4:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.4
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable introspection)"
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+}