summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/totem-pl-parser/Manifest11
-rw-r--r--dev-libs/totem-pl-parser/metadata.xml13
-rw-r--r--dev-libs/totem-pl-parser/totem-pl-parser-3.10.0.ebuild64
-rw-r--r--dev-libs/totem-pl-parser/totem-pl-parser-9999.ebuild73
4 files changed, 124 insertions, 37 deletions
diff --git a/dev-libs/totem-pl-parser/Manifest b/dev-libs/totem-pl-parser/Manifest
new file mode 100644
index 00000000..bec36bc4
--- /dev/null
+++ b/dev-libs/totem-pl-parser/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST totem-pl-parser-3.10.0.tar.xz 1600756 SHA256 87eac3fdf2b632dfac0edda07906a3e84f1ce4442b8127394414020dafe41aa9 SHA512 9f5b7c307a936e7f5ea1d407b084a7b1d4ecc5ee13cbe93c5f4abbfab00d8d4c8e6c90a6f6fe7f564a9891bc7f96582f8c28b86157d01293b7f8514252288f25 WHIRLPOOL 8dfd131afd6fbba52e551c7890f28cdef59f8d2e16f4da627448281c4b2278a9b8ceeb7507790240099d91de2525ac0b5d103fd306b06174ce4d04e2ec9b256f
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.21 (GNU/Linux)
+
+iEYEAREKAAYFAlKWf4QACgkQ1fmVwcYIWAaAPwCgwlQZaPxtxyRTQLCWhGyQxAVa
+Au4AnitV0US6lbWNIwXq3f4cbtIPazwE
+=/faX
+-----END PGP SIGNATURE-----
diff --git a/dev-libs/totem-pl-parser/metadata.xml b/dev-libs/totem-pl-parser/metadata.xml
new file mode 100644
index 00000000..4c6d9e95
--- /dev/null
+++ b/dev-libs/totem-pl-parser/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name='archive'>Enables support for accessing media files in archives
+ transparently via <pkg>app-arch/libarchive</pkg></flag>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for
+ introspection</flag>
+ <flag name="quvi">Use <pkg>media-libs/quvi</pkg> for parsing video
+ links</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-libs/totem-pl-parser/totem-pl-parser-3.10.0.ebuild b/dev-libs/totem-pl-parser/totem-pl-parser-3.10.0.ebuild
new file mode 100644
index 00000000..d45bd043
--- /dev/null
+++ b/dev-libs/totem-pl-parser/totem-pl-parser-3.10.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Playlist parsing library"
+HOMEPAGE="http://projects.gnome.org/totem/ http://developer.gnome.org/totem-pl-parser/stable/"
+
+LICENSE="LGPL-2+"
+SLOT="0/18"
+IUSE="archive crypt +introspection +quvi test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.31:2
+ dev-libs/gmime:2.6
+ >=net-libs/libsoup-2.43:2.4
+ archive? ( >=app-arch/libarchive-3 )
+ crypt? ( dev-libs/libgcrypt )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ quvi? ( >=media-libs/libquvi-0.9.1:0= )
+"
+DEPEND="${RDEPEND}
+ !<media-video/totem-2.21
+ >=dev-util/intltool-0.35
+ >=dev-util/gtk-doc-am-1.14
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ test? (
+ gnome-base/gvfs[http]
+ sys-apps/dbus )
+"
+# eautoreconf needs:
+# dev-libs/gobject-introspection-common
+# >=gnome-base/gnome-common-3.6
+
+src_prepare() {
+ # Disable tests requiring network access, bug #346127
+ # 3rd test fails on upgrade, not once installed
+ sed -e 's:\(g_test_add_func.*/parser/resolution.*\):/*\1*/:' \
+ -e 's:\(g_test_add_func.*/parser/parsing/itms_link.*\):/*\1*/:' \
+ -e 's:\(g_test_add_func.*/parser/parsability.*\)/*\1/:'\
+ -i plparse/tests/parser.c || die "sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable archive libarchive) \
+ $(use_enable crypt libgcrypt) \
+ $(use_enable quvi) \
+ $(use_enable introspection)
+}
+
+src_test() {
+ # This is required as told by upstream in bgo#629542
+ GVFS_DISABLE_FUSE=1 dbus-launch emake check || die "emake check failed"
+}
diff --git a/dev-libs/totem-pl-parser/totem-pl-parser-9999.ebuild b/dev-libs/totem-pl-parser/totem-pl-parser-9999.ebuild
index f3a05535..1bb6138d 100644
--- a/dev-libs/totem-pl-parser/totem-pl-parser-9999.ebuild
+++ b/dev-libs/totem-pl-parser/totem-pl-parser-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI="5"
GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
inherit gnome2
if [[ ${PV} = 9999 ]]; then
@@ -14,62 +13,62 @@ fi
DESCRIPTION="Playlist parsing library"
HOMEPAGE="http://projects.gnome.org/totem/ http://developer.gnome.org/totem-pl-parser/stable/"
-LICENSE="LGPL-2"
-SLOT="0"
+LICENSE="LGPL-2+"
+SLOT="0/18"
+IUSE="archive crypt +introspection +quvi test"
if [[ ${PV} = 9999 ]]; then
+ IUSE="${IUSE} doc"
KEYWORDS=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~sparc ~x86 ~x86-fbsd"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
fi
-IUSE="archive crypt doc +introspection +quvi test"
-RDEPEND=">=dev-libs/glib-2.31:2
- dev-libs/gmime:2.4
- >=net-libs/libsoup-gnome-2.30:2.4
- archive? ( >=app-arch/libarchive-2.8.4 )
+RDEPEND="
+ >=dev-libs/glib-2.31:2
+ dev-libs/gmime:2.6
+ >=net-libs/libsoup-2.43:2.4
+ archive? ( >=app-arch/libarchive-3 )
crypt? ( dev-libs/libgcrypt )
introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
- quvi? ( >=media-libs/libquvi-0.2.15 )"
+ quvi? ( >=media-libs/libquvi-0.9.1:0= )
+"
DEPEND="${RDEPEND}
!<media-video/totem-2.21
>=dev-util/intltool-0.35
+ >=dev-util/gtk-doc-am-1.14
>=sys-devel/gettext-0.17
virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.14 )
test? (
gnome-base/gvfs[http]
- sys-apps/dbus )"
+ sys-apps/dbus )
+"
# eautoreconf needs:
-# >=dev-util/gtk-doc-am-1.14
+# dev-libs/gobject-introspection-common
+# >=gnome-base/gnome-common-3.6
-pkg_setup() {
- G2CONF="${G2CONF}
- --disable-static
- --disable-maintainer-mode
- $(use_enable archive libarchive)
- $(use_enable crypt libgcrypt)
- $(use_enable quvi)
- $(use_enable introspection)"
- DOCS="AUTHORS ChangeLog NEWS"
-}
-
-# eautoreconf needs:
-#src_unpack() {
-# # If gobject-introspection is installed, we don't need the extra .m4
-# if has_version "dev-libs/gobject-introspection"; then
-# unpack ${P}.tar.bz2
-# else
-# unpack ${A}
-# fi
-#}
+if [[ ${PV} = 9999 ]]; then
+ DEPEND="${DEPEND}
+ doc? ( >=dev-util/gtk-doc-1.14 )"
+fi
src_prepare() {
- gnome2_src_prepare
-
# Disable tests requiring network access, bug #346127
+ # 3rd test fails on upgrade, not once installed
sed -e 's:\(g_test_add_func.*/parser/resolution.*\):/*\1*/:' \
-e 's:\(g_test_add_func.*/parser/parsing/itms_link.*\):/*\1*/:' \
+ -e 's:\(g_test_add_func.*/parser/parsability.*\)/*\1/:'\
-i plparse/tests/parser.c || die "sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable archive libarchive) \
+ $(use_enable crypt libgcrypt) \
+ $(use_enable quvi) \
+ $(use_enable introspection)
}
src_test() {