summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/eog/eog-9999.ebuild')
-rw-r--r--media-gfx/eog/eog-9999.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/media-gfx/eog/eog-9999.ebuild b/media-gfx/eog/eog-9999.ebuild
deleted file mode 100644
index 11661918..00000000
--- a/media-gfx/eog/eog-9999.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="The Eye of GNOME image viewer"
-HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome"
-
-LICENSE="GPL-2+"
-SLOT="1"
-IUSE="+exif +introspection +jpeg lcms +svg tiff xmp"
-if [[ ${PV} = 9999 ]]; then
- IUSE="${IUSE} doc"
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-fi
-
-REQUIRED_USE="exif? ( jpeg )"
-
-RDEPEND="
- >=dev-libs/glib-2.42.0:2[dbus]
- >=dev-libs/libpeas-0.7.4:=[gtk]
- >=gnome-base/gnome-desktop-2.91.2:3=
- >=gnome-base/gsettings-desktop-schemas-2.91.92
- >=x11-libs/gtk+-3.19.3:3[introspection,X]
- >=x11-misc/shared-mime-info-0.20
-
- >=x11-libs/gdk-pixbuf-2.30.0:2[jpeg?,tiff?]
- x11-libs/libX11
-
- exif? ( >=media-libs/libexif-0.6.14 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
- jpeg? ( virtual/jpeg:0 )
- lcms? ( media-libs/lcms:2 )
- svg? ( >=gnome-base/librsvg-2.36.2:2 )
- xmp? ( media-libs/exempi:2 )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.16
- >=dev-util/intltool-0.50.1
- dev-util/itstool
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- app-text/yelp-tools
- doc? ( >=dev-util/gtk-doc-1.16 )"
-fi
-
-src_configure() {
- local myconf=""
- [[ ${PV} != 9999 ]] && myconf="ITSTOOL=$(type -P true)"
- DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README THANKS TODO"
- gnome2_src_configure \
- $(use_enable introspection) \
- $(use_with jpeg libjpeg) \
- $(use_with exif libexif) \
- $(use_with lcms cms) \
- $(use_with xmp) \
- $(use_with svg librsvg) \
- ${myconf}
-}