summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libzapojit/libzapojit-9999.ebuild')
-rw-r--r--net-libs/libzapojit/libzapojit-9999.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/net-libs/libzapojit/libzapojit-9999.ebuild b/net-libs/libzapojit/libzapojit-9999.ebuild
deleted file mode 100644
index ebac3ab7..00000000
--- a/net-libs/libzapojit/libzapojit-9999.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-
-inherit gnome2
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="GLib/GObject wrapper for the SkyDrive and Hotmail REST APIs"
-HOMEPAGE="http://git.gnome.org/browse/libzapojit"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="+introspection"
-if [[ ${PV} = 9999 ]]; then
- IUSE="${IUSE} doc"
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-fi
-
-RDEPEND="
- >=dev-libs/glib-2.28:2
- >=net-libs/libsoup-2.38:2.4
- dev-libs/json-glib
- net-libs/rest
- net-libs/gnome-online-accounts
-
- introspection? ( >=dev-libs/gobject-introspection-1.30.0 )"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.11
- >=dev-util/intltool-0.35.0
- sys-devel/gettext
- virtual/pkgconfig
-"
-# eautoreconf needs:
-# gnome-base/gnome-common:3
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- gnome-base/gnome-common:3
- doc? ( >=dev-util/gtk-doc-1.11 )"
-fi
-
-src_configure() {
- gnome2_src_configure \
- --enable-compile-warnings=minimum \
- --disable-static \
- $(use_enable introspection)
-}
-
-src_install() {
- gnome2_src_install
- # Drop self-installed documentation
- rm -r "${ED}"/usr/share/doc/${PN}/ || die
-}