summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-3.18-r99.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-3.18-r99.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-3.18-r99.ebuild b/sys-kernel/linux-headers/linux-headers-3.18-r99.ebuild
deleted file mode 100644
index d9113b80..00000000
--- a/sys-kernel/linux-headers/linux-headers-3.18-r99.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-3.18.ebuild,v 1.3 2015/03/24 20:13:13 maekke Exp $
-
-EAPI="4"
-
-ETYPE="headers"
-H_SUPPORTEDARCH="alpha amd64 arc arm arm64 avr32 bfin cris frv hexagon hppa ia64 m32r m68k metag microblaze mips mn10300 openrisc ppc ppc64 s390 score sh sparc tile x86 xtensa"
-inherit kernel-2
-detect_version
-
-PATCH_VER="1"
-SRC_URI="mirror://gentoo/gentoo-headers-base-${PV}.tar.xz
- ${PATCH_VER:+mirror://gentoo/gentoo-headers-${PV}-${PATCH_VER}.tar.xz}"
-
-KEYWORDS="amd64 arm ~mips ppc x86"
-
-DEPEND="app-arch/xz-utils
- dev-lang/perl"
-RDEPEND="!!media-sound/alsa-headers"
-
-S=${WORKDIR}/gentoo-headers-base-${PV}
-
-src_unpack() {
- unpack ${A}
-}
-
-src_prepare() {
- [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/${PV}
- epatch "${FILESDIR}"/glibc-specific-inclusion-of-sysinfo.h-in-kernel.h.patch
- epatch "${FILESDIR}"/libc-compat.h-fix-some-issues-arising-from-in6.h.patch
- epatch "${FILESDIR}"/libc-compat.h-prevent-redefinition-of-struct-ethhdr.patch
-}
-
-src_install() {
- kernel-2_src_install
-
- # hrm, build system sucks
- find "${ED}" '(' -name '.install' -o -name '*.cmd' ')' -delete
- find "${ED}" -depth -type d -delete 2>/dev/null
-
- # provided by libdrm (for now?)
- rm -rf "${ED}"/$(kernel_header_destdir)/drm
-}
-
-src_test() {
- einfo "Possible unescaped attribute/type usage"
- egrep -r \
- -e '(^|[[:space:](])(asm|volatile|inline)[[:space:](]' \
- -e '\<([us](8|16|32|64))\>' \
- .
-
- einfo "Missing linux/types.h include"
- egrep -l -r -e '__[us](8|16|32|64)' "${ED}" | xargs grep -L linux/types.h
-
- emake ARCH=$(tc-arch-kernel) headers_check
-}