aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <cpebenito@tresys.com>2013-06-06 09:27:40 -0400
committerSven Vermeulen <sven.vermeulen@siphos.be>2013-08-15 10:35:19 +0200
commit3b16993d1789c1eeeb5df4aab7be75802c97571c (patch)
tree1a350da5c85b1c35a7dc155d93361fd1b87ef337 /Makefile
parentImprove style (diff)
downloadhardened-refpolicy-3b16993d1789c1eeeb5df4aab7be75802c97571c.tar.gz
hardened-refpolicy-3b16993d1789c1eeeb5df4aab7be75802c97571c.tar.bz2
hardened-refpolicy-3b16993d1789c1eeeb5df4aab7be75802c97571c.zip
Use python libselinux bindings to determine policy version.
This eliminates the hardcoded /selinux in Rules.monolithic, which broke when the filesystem mount was moved to /sys/fs/selinux.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e012cd88..bc475808 100644
--- a/Makefile
+++ b/Makefile
@@ -97,6 +97,7 @@ support := support
genxml := $(PYTHON) -E $(support)/segenxml.py
gendoc := $(PYTHON) -E $(support)/sedoctool.py
genperm := $(PYTHON) -E $(support)/genclassperms.py
+policyvers := $(PYTHON) -E $(support)/policyvers.py
fcsort := $(tmpdir)/fc_sort
setbools := $(AWK) -f $(support)/set_bools_tuns.awk
get_type_attr_decl := $(SED) -r -f $(support)/get_type_attr_decl.sed