aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer-gentoo@users.noreply.github.com>2016-09-01 12:14:03 +0200
committerJason Zaman <jason@perfinion.com>2016-10-03 14:04:21 +0800
commit96e624901f8ea8b2a57e0274d89c6e4a3eb991d6 (patch)
tree1432b9cd084b525cd21fcd5f4b8c681c4c3bbfd6 /Makefile
parentMerge upstream (diff)
downloadhardened-refpolicy-96e624901f8ea8b2a57e0274d89c6e4a3eb991d6.tar.gz
hardened-refpolicy-96e624901f8ea8b2a57e0274d89c6e4a3eb991d6.tar.bz2
hardened-refpolicy-96e624901f8ea8b2a57e0274d89c6e4a3eb991d6.zip
Use $(AWK) not plain awk
Since the awk scripts appear to use some GNU extensions, make sure we always use $(AWK). Fixes an issue where the system /usr/bin/awk may be another implementation, say mawk on a Ubuntu system.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 76edb27e5..b570ff101 100644
--- a/Makefile
+++ b/Makefile
@@ -295,9 +295,9 @@ cmdline_mods := $(addsuffix .te,$(APPS_MODS))
cmdline_off := $(addsuffix .te,$(APPS_OFF))
# extract settings from modules.conf
-mod_conf_base := $(addsuffix .te,$(sort $(shell awk '/^[[:blank:]]*[[:alpha:]]/{ if ($$3 == "$(configbase)") print $$1 }' $(mod_conf) 2> /dev/null)))
-mod_conf_mods := $(addsuffix .te,$(sort $(shell awk '/^[[:blank:]]*[[:alpha:]]/{ if ($$3 == "$(configmod)") print $$1 }' $(mod_conf) 2> /dev/null)))
-mod_conf_off := $(addsuffix .te,$(sort $(shell awk '/^[[:blank:]]*[[:alpha:]]/{ if ($$3 == "$(configoff)") print $$1 }' $(mod_conf) 2> /dev/null)))
+mod_conf_base := $(addsuffix .te,$(sort $(shell $(AWK) '/^[[:blank:]]*[[:alpha:]]/{ if ($$3 == "$(configbase)") print $$1 }' $(mod_conf) 2> /dev/null)))
+mod_conf_mods := $(addsuffix .te,$(sort $(shell $(AWK) '/^[[:blank:]]*[[:alpha:]]/{ if ($$3 == "$(configmod)") print $$1 }' $(mod_conf) 2> /dev/null)))
+mod_conf_off := $(addsuffix .te,$(sort $(shell $(AWK) '/^[[:blank:]]*[[:alpha:]]/{ if ($$3 == "$(configoff)") print $$1 }' $(mod_conf) 2> /dev/null)))
base_mods := $(cmdline_base)
mod_mods := $(cmdline_mods)
@@ -311,7 +311,7 @@ off_mods += $(filter-out $(cmdline_off) $(cmdline_base) $(cmdline_mods), $(mod_c
off_mods += $(filter-out $(base_mods) $(mod_mods) $(off_mods),$(notdir $(detected_mods)))
# filesystems to be used in labeling targets
-filesystems = $(shell mount | grep -v "context=" | egrep -v '\((|.*,)bind(,.*|)\)' | awk '/(ext[234]|btrfs| xfs| jfs).*rw/{print $$3}';)
+filesystems = $(shell mount | grep -v "context=" | egrep -v '\((|.*,)bind(,.*|)\)' | $(AWK) '/(ext[234]|btrfs| xfs| jfs).*rw/{print $$3}';)
fs_names := "btrfs ext2 ext3 ext4 xfs jfs"
########################################