diff options
author | Chris PeBenito <pebenito@ieee.org> | 2017-02-18 10:20:20 -0500 |
---|---|---|
committer | Jason Zaman <jason@perfinion.com> | 2017-02-21 14:55:55 +0800 |
commit | 99249f103339619913cf5c17abb8fd0fd893d9b0 (patch) | |
tree | 4b87cdba9747a1c3c46695e247ec464b0d686493 /Makefile | |
parent | Little misc patches from Russell Coker. (diff) | |
download | hardened-refpolicy-99249f103339619913cf5c17abb8fd0fd893d9b0.tar.gz hardened-refpolicy-99249f103339619913cf5c17abb8fd0fd893d9b0.tar.bz2 hardened-refpolicy-99249f103339619913cf5c17abb8fd0fd893d9b0.zip |
Implement WERROR build option to treat warnings as errors.
Add this to all Travis-CI builds.
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 5 |
1 files changed, 5 insertions, 0 deletions
@@ -106,6 +106,7 @@ gennetfilter := $(PYTHON) -E $(support)/gennetfilter.py m4iferror := $(support)/iferror.m4 m4divert := $(support)/divert.m4 m4undivert := $(support)/undivert.m4 +m4terminate := $(support)/fatal_error.m4 # use our own genhomedircon to make sure we have a known usable one, # so policycoreutils updates are not required (RHEL4) genhomedircon := $(PYTHON) -E $(support)/genhomedircon @@ -214,6 +215,10 @@ ifeq ($(DIRECT_INITRC),y) M4PARAM += -D direct_sysadm_daemon endif +ifeq "$(WERROR)" "y" + M4PARAM += -D m4_werror +endif + ifeq "$(UBAC)" "y" M4PARAM += -D enable_ubac endif |