aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--NEWS1
-rw-r--r--src/meson.build6
2 files changed, 5 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 2faa9d9..1fa9a89 100644
--- a/NEWS
+++ b/NEWS
@@ -4,6 +4,7 @@ For full ChangeLog generated from svn commit logs see ChangeLog.
2.3.4:
* Install java-config-2 as java-config from now on
+* Fix launcher installation in Gentoo-prefix installations (#933521)
2.3.3 / 2.3.2:
* Correctly set java.library.path in launcher
diff --git a/src/meson.build b/src/meson.build
index c80b814..bdfaa31 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -20,9 +20,11 @@ if python_only
subdir_done()
endif
+prefix = get_option('prefix')
+
launcherdir_rel = 'share' / 'java-config-2' / 'launcher'
-launcherdir = system_wide ? eprefix / launcherdir_rel \
- : datadir / eprefix / launcherdir_rel
+launcherdir = system_wide ? prefix / launcherdir_rel \
+ : datadir / prefix / launcherdir_rel
launcher_bash = configure_file(
input: 'launcher.bash',