summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-23 15:40:24 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-23 15:40:24 +0200
commita13a24f9d1634d3b6fb44a4a7bab7afc845aecef (patch)
tree24de6d26591d59f63a95673cfe6b3bd005266703 /app-crypt
parentkde-base/kdvi: EAPI-4 bump to fix fatal error w/ elisp-common.eclass (diff)
downloadkde-sunset-a13a24f9d1634d3b6fb44a4a7bab7afc845aecef.tar.gz
kde-sunset-a13a24f9d1634d3b6fb44a4a7bab7afc845aecef.tar.bz2
kde-sunset-a13a24f9d1634d3b6fb44a4a7bab7afc845aecef.zip
app-crypt/qca: Add 2.2.1 as the last upstream version supporting Qt4
- New SLOT="2-qt4" to be able to install it side-by side w/ Qt5 version - Block colliding SLOT="2" versions <2.2.90 - Drop broken libressl support, bug #709288 - Supports dev-libs/botan:2 and openssl-1.1, bug #592526 Package-Manager: Portage-3.0.4, Repoman-3.0.1 RepoMan-Options: --force Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/qca/Manifest1
-rw-r--r--app-crypt/qca/qca-2.2.1.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-crypt/qca/Manifest b/app-crypt/qca/Manifest
index bed2df91..3a333404 100644
--- a/app-crypt/qca/Manifest
+++ b/app-crypt/qca/Manifest
@@ -1,2 +1,3 @@
DIST qca-1.0.tar.bz2 30677 BLAKE2B f85b76632f7f4997c70976764ba74bf3314b850f82bdce1d2d0e176268503c279d0eae98abe762cecbfd2bf523295e2178cd8b667ad5a8f6c45c4dc91ba7cbb8 SHA512 50a0017eaf75d0d896c6f142ab39ef6bd75cfd7f5712f9f059b65b5e0230f04f385c62a7a67ae24f820afe8109578108aa860306e47909038fb7b999a0dcd918
DIST qca-2.1.3.tar.xz 686340 BLAKE2B 60ebf9add907632ed17426ee53c6c35a9aed279a4492012f1c174608cbe9579d366feb7ff7bff551d2e9e4ef2f271e8f340fcb4c9e1f67f209657d388567d44f SHA512 0aec277e0695da2e45298f0a9006213829fe4c449a79969e472947db54f45000ba6e22361b782465bdc03f269b7301d318c843f5a83db459a118e58a03f3116a
+DIST qca-2.2.1.tar.xz 691676 BLAKE2B d5bcc0d6e791811e1efcdbf2e09916fe40ad682b0e59b2993c73a5bd79e09fc28facdec81259a982bee05223c8dfce78b9a6b729ca4e566c0901a13b91575379 SHA512 3a0e8aa7cf3ea9a7244facaf1d521ebca2753af37636e7bf5f21c57ae880ac9682ae7d6d9fa5ce41b73568ff9538214956b89cd41228c2cb828d9068c2031a9c
diff --git a/app-crypt/qca/qca-2.2.1.ebuild b/app-crypt/qca/qca-2.2.1.ebuild
new file mode 100644
index 00000000..89051d6d
--- /dev/null
+++ b/app-crypt/qca/qca-2.2.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils qmake-utils
+
+DESCRIPTION="Qt Cryptographic Architecture (QCA)"
+HOMEPAGE="https://userbase.kde.org/QCA"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="2-qt4"
+KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+
+IUSE="botan debug doc examples gcrypt gpg logger nss pkcs11 sasl softstore +ssl test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+COMMON_DEPEND="
+ >=dev-qt/qtcore-4.8.7-r2:4
+ botan? ( dev-libs/botan:= )
+ gcrypt? ( dev-libs/libgcrypt:= )
+ gpg? ( app-crypt/gnupg )
+ nss? ( dev-libs/nss )
+ pkcs11? (
+ dev-libs/openssl:0
+ dev-libs/pkcs11-helper
+ )
+ sasl? ( dev-libs/cyrus-sasl:2 )
+ ssl? ( >=dev-libs/openssl-1.0.1:0= )
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-qt/qttest:4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<app-crypt/qca-2.2.90:2
+ !app-crypt/qca-cyrus-sasl
+ !app-crypt/qca-gnupg
+ !app-crypt/qca-logger
+ !app-crypt/qca-ossl
+ !app-crypt/qca-pkcs11
+"
+
+PATCHES=( "${FILESDIR}/${PN}-disable-pgp-test.patch" )
+
+qca_plugin_use() {
+ echo -DWITH_${2:-$1}_PLUGIN=$(usex "$1")
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT4_BUILD=ON
+ -DQCA_FEATURE_INSTALL_DIR="${EPREFIX}$(qt4_get_mkspecsdir)/features"
+ -DQCA_PLUGINS_INSTALL_DIR="${EPREFIX}$(qt4_get_plugindir)"
+ $(qca_plugin_use botan)
+ $(qca_plugin_use gcrypt)
+ $(qca_plugin_use gpg gnupg)
+ $(qca_plugin_use logger)
+ $(qca_plugin_use nss)
+ $(qca_plugin_use pkcs11)
+ $(qca_plugin_use sasl cyrus-sasl)
+ $(qca_plugin_use softstore)
+ $(qca_plugin_use ssl ossl)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ local -x QCA_PLUGIN_PATH="${BUILD_DIR}/lib/qca"
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc; then
+ pushd "${BUILD_DIR}" >/dev/null || die
+ doxygen Doxyfile || die
+ dodoc -r apidocs/html
+ popd >/dev/null || die
+ fi
+
+ if use examples; then
+ dodoc -r "${S}"/examples
+ fi
+}