aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-16 21:39:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-16 21:49:47 +0200
commitcdc00ad8491f35e7b94be2c40ea95bf90f6fa4c2 (patch)
tree0c718b67fe51c6de1f9334f91b74aaaabd55e203
parentkde-apps/cervisia: 24.08.0 version bump (diff)
downloadkde-cdc00ad8491f35e7b94be2c40ea95bf90f6fa4c2.tar.gz
kde-cdc00ad8491f35e7b94be2c40ea95bf90f6fa4c2.tar.bz2
kde-cdc00ad8491f35e7b94be2c40ea95bf90f6fa4c2.zip
kde-apps/dolphin-plugins-git: 24.08.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-24.08.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index c0ca61b416..eadb90f845 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-24.07.90.tar.xz 316724 BLAKE2B a5f767042003744aa89af02f088e17004d02d95c8e37954a74fed6748938464e429fa63d6b027c419c22bbcfbccab1b6ae06cc8d52adc21fe2598c5ca7955b98 SHA512 3d23a33a22fa66025b198a5a312585527f8f06b2e265f80004ff772690a4e6dc33f7c9750b75a891eeb9cc6561827e3922757d976ad8b9de92747400663267c8
+DIST dolphin-plugins-24.08.0.tar.xz 316660 BLAKE2B 00140dcea345f15caa0bbb50845ad4719cf92420c505ad510c505e9e7a4d0ea8aeb4cd23133bca0f44de34bbf98704545eb9c28f34d5fc8988f2b2154e3db8c2 SHA512 8d72253ecf3b44b4a81ff4ab952913683b2b679220620f153dae4b045e008faccc768e40e48d6dbf41a49a15409e4fa728feee30decbf2a4a35741bf9db87fa3
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-24.08.0.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-24.08.0.ebuild
new file mode 100644
index 0000000000..6eea529ebc
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-24.08.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}