summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyprien Nicolas (fulax) <c.nicolas+gentoo@gmail.com>2010-10-22 13:33:50 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2018-03-09 22:33:25 +0100
commitc37fd94bef3e7d9b27a99f6a790f669ca717cc0a (patch)
tree50c52dba839670d071b6def306a35cf80a9aff26 /app-text/skribe
parentdev-scheme/hop-2.2.0-pre3: Version bump. (diff)
downloadlisp-c37fd94bef3e7d9b27a99f6a790f669ca717cc0a.tar.gz
lisp-c37fd94bef3e7d9b27a99f6a790f669ca717cc0a.tar.bz2
lisp-c37fd94bef3e7d9b27a99f6a790f669ca717cc0a.zip
app-text/skribe-1.2l-r1: Fix bug #340667. Add patch for sandbox violation if bigloo was built with USE=emacs.
Diffstat (limited to 'app-text/skribe')
-rw-r--r--app-text/skribe/Manifest3
-rw-r--r--app-text/skribe/files/skribe-1.2l-proper_skribe_el_installation.patch14
-rw-r--r--app-text/skribe/skribe-1.2l-r1.ebuild50
3 files changed, 67 insertions, 0 deletions
diff --git a/app-text/skribe/Manifest b/app-text/skribe/Manifest
new file mode 100644
index 00000000..a8a28310
--- /dev/null
+++ b/app-text/skribe/Manifest
@@ -0,0 +1,3 @@
+AUX skribe-1.2l-proper_skribe_el_installation.patch 478 RMD160 197e0c2345488ac97be23b8bae3ac87d4920e87d SHA1 adf97ed0e59b14462c3505937f3183fd7c1bee85 SHA256 e08efcaddae24d513f1a32f0f5dae50c462ef7ece3f832895599b3ec0537ac32
+DIST skribe1.2l.tar.gz 245007 RMD160 5f4c272bd7c1973cc74b6f4fdf62c5f77dae4f25 SHA1 0817c383dc7f1ad5013de6a4d9246443a5f7d0d9 SHA256 87bc31b7c087070f27be2be816b322993972bbf03fb72cbd0d7603796d5636d0
+EBUILD skribe-1.2l-r1.ebuild 1319 RMD160 4a81cf3b3c4b6e5d4996f452ead158426e48ef82 SHA1 8f7258bf4b25a3886b4356d8de6691eb8386f2a8 SHA256 b081b0b63983ba65ab6c291697d4d398b3060b786d7c7745a18b6faffb969658
diff --git a/app-text/skribe/files/skribe-1.2l-proper_skribe_el_installation.patch b/app-text/skribe/files/skribe-1.2l-proper_skribe_el_installation.patch
new file mode 100644
index 00000000..4832d5d5
--- /dev/null
+++ b/app-text/skribe/files/skribe-1.2l-proper_skribe_el_installation.patch
@@ -0,0 +1,14 @@
+diff --git a/emacs/Makefile b/emacs/Makefile
+--- a/emacs/Makefile
++++ b/emacs/Makefile
+@@ -32,7 +32,9 @@ uninstall:
+ install-bigloo:
+ if [ "$(EMACSDIR) " != " " ]; then \
+ if [ -d $(EMACSDIR) ]; then \
+- cp skribe.el $(EMACSDIR) && chmod $(BMASK) $(EMACSDIR)/skribe.el; \
++ mkdir -p $(DESTDIR)$(EMACSDIR) && \
++ cp skribe.el $(DESTDIR)$(EMACSDIR) && \
++ chmod $(BMASK) $(DESTDIR)$(EMACSDIR)/skribe.el; \
+ fi \
+ fi
+ uninstall-bigloo:
diff --git a/app-text/skribe/skribe-1.2l-r1.ebuild b/app-text/skribe/skribe-1.2l-r1.ebuild
new file mode 100644
index 00000000..bf555d36
--- /dev/null
+++ b/app-text/skribe/skribe-1.2l-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/skribe/skribe-1.2l.ebuild,v 1.3 2010/09/15 21:47:28 chiiph Exp $
+
+EAPI="3"
+
+inherit multilib eutils
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Skribe is a text processor for technical documents written in scheme."
+HOMEPAGE="http://www-sop.inria.fr/mimosa/fp/Skribe/"
+SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Skribe/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-scheme/bigloo"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # falsify bigloo auto-strip feature to prevent pre-stripped QA errors
+ sed -r 's/^blinkflags="(.*)"$/blinkflags="\1 -eval '\''(set! *strip* \\#f)'\''"/gi' \
+ -i ./etc/bigloo/configure || die "sed failed"
+
+ # Put the new emacs file (only if bigloo[emacs]) in DESTDIR instead of live filesystem
+ epatch "${FILESDIR}/${P}-proper_skribe_el_installation.patch"
+}
+
+src_configure() {
+ ./configure \
+ --with-bigloo \
+ --ldopt="${LDFLAGS}" \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --libdir=/usr/$(get_libdir) \
+ --docdir=/usr/share/doc/${PF} || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}