summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-base/xorg-server/files')
-rw-r--r--x11-base/xorg-server/files/1.7.5.902-fix-tslib-1.0-check.patch19
-rwxr-xr-xx11-base/xorg-server/files/xdm.initd-2202
-rw-r--r--x11-base/xorg-server/files/xorg-server-1.9.0-loongson.patch53
-rw-r--r--x11-base/xorg-server/files/xorg-server-1.9.2.902-loongson.patch53
4 files changed, 0 insertions, 327 deletions
diff --git a/x11-base/xorg-server/files/1.7.5.902-fix-tslib-1.0-check.patch b/x11-base/xorg-server/files/1.7.5.902-fix-tslib-1.0-check.patch
deleted file mode 100644
index 3675822..0000000
--- a/x11-base/xorg-server/files/1.7.5.902-fix-tslib-1.0-check.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- configure.ac 2010-03-16 22:24:14.000000000 +0100
-+++ configure.ac.new 2010-03-16 22:33:10.000000000 +0100
-@@ -1915,8 +1915,14 @@
- AC_DEFINE(KDRIVEFBDEV, 1, [Build fbdev-based kdrive server])
- fi
-
--
-- PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [HAVE_TSLIB="yes"], [HAVE_TSLIB="no"])
-+dnl Do tripple check for tslib in the transition phase to unversioned pkgconfig files...
-+ PKG_CHECK_MODULES([TSLIB], [tslib], [HAVE_TSLIB="yes"], [
-+ PKG_CHECK_MODULES([TSLIB], [tslib-1.0], [HAVE_TSLIB="yes"], [
-+ PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [HAVE_TSLIB="yes"], [
-+ HAVE_TSLIB="no"
-+ ])
-+ ])
-+ ])
- if test "x$HAVE_TSLIB" = xno; then
- AC_CHECK_LIB(ts, ts_open, [HAVE_TSLIB="yes"])
- fi
diff --git a/x11-base/xorg-server/files/xdm.initd-2 b/x11-base/xorg-server/files/xdm.initd-2
deleted file mode 100755
index e8e954e..0000000
--- a/x11-base/xorg-server/files/xdm.initd-2
+++ /dev/null
@@ -1,202 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/files/xdm.initd,v 1.1 2010/04/13 10:07:39 scarabeus Exp $
-
-# This is here to serve as a note to myself, and future developers.
-#
-# Any Display manager (gdm,kdm,xdm) has the following problem: if
-# it is started before any getty, and no vt is specified, it will
-# usually run on vt2. When the getty on vt2 then starts, and the
-# DM is already started, the getty will take control of the keyboard,
-# leaving us with a "dead" keyboard.
-#
-# Resolution: add the following line to /etc/inittab
-#
-# x:a:once:/etc/X11/startDM.sh
-#
-# and have /etc/X11/startDM.sh start the DM in daemon mode if
-# a lock is present (with the info of what DM should be started),
-# else just fall through.
-#
-# How this basically works, is the "a" runlevel is a additional
-# runlevel that you can use to fork processes with init, but the
-# runlevel never gets changed to this runlevel. Along with the "a"
-# runlevel, the "once" key word means that startDM.sh will only be
-# run when we specify it to run, thus eliminating respawning
-# startDM.sh when "xdm" is not added to the default runlevel, as was
-# done previously.
-#
-# This script then just calls "telinit a", and init will run
-# /etc/X11/startDM.sh after the current runlevel completes (this
-# script should only be added to the actual runlevel the user is
-# using).
-#
-# Martin Schlemmer
-# aka Azarah
-# 04 March 2002
-
-depend() {
- need localmount xdm
-
- # this should start as early as possible
- # we can't do 'before *' as that breaks it
- # (#139824) Start after ypbind and autofs for network authentication
- # (#145219 #180163) Could use lirc mouse as input device
- # (#70689 comment #92) Start after consolefont to avoid display corruption
- # (#291269) Start after quota, since some dm need readable home
- after bootmisc consolefont modules netmount
- after readahead-list ypbind autofs openvpn gpm lircmd
- after quota
- before alsasound
-
- # Start before X
- use consolekit xfs
-}
-
-setup_dm() {
- local MY_XDM="$(echo "${DISPLAYMANAGER}" | tr '[:upper:]' '[:lower:]')"
-
- # Load our root path from profile.env
- # Needed for kdm
- PATH="${PATH}:$(. /etc/profile.env; echo "${ROOTPATH}")"
-
- case "${MY_XDM}" in
- kdm|kde)
- EXE="$(which kdm)"
- PIDFILE=/var/run/kdm.pid
- ;;
- kdm-*)
- EXE="/usr/kde/${MY_XDM#kdm-}/bin/kdm"
- PIDFILE=/var/run/kdm.pid
- ;;
- entrance*)
- EXE=/usr/sbin/entranced
- PIDFILE=/var/lib/entranced.pid
- ;;
- gdm|gnome)
- EXE=/usr/bin/gdm
- [ "${RC_UNAME}" != "Linux" ] && NAME=gdm-binary
- PIDFILE=/var/run/gdm.pid
- ;;
- wdm)
- EXE=/usr/bin/wdm
- PIDFILE=
- ;;
- gpe)
- EXE=/usr/bin/gpe-dm
- PIDFILE=/var/run/gpe-dm.pid
- ;;
- *)
- # first find out if there is such executable
- EXE="$(which ${MY_XDM} 2>/dev/null)"
- PIDFILE="/var/run/${MY_XDM}.pid"
-
- # warn user that he is doing sick things if the exe was not found
- if [ "${EXE}" = "" ]; then
- echo "ERROR: Your XDM value is invalid."
- echo " No ${MY_XDM} executable could be found on your system."
- fi
- ;;
- esac
-
- if ! [ -x "${EXE}" ]; then
- EXE=/usr/bin/xdm
- PIDFILE=/var/run/xdm.pid
- if ! [ -x "/usr/bin/xdm" ]; then
- echo "ERROR: Please set your DISPLAYMANAGER variable in /etc/conf.d/xdm,"
- echo " or install x11-apps/xdm package"
- eend 255
- fi
- fi
-}
-
-# Check to see if something is defined on our VT
-vtstatic() {
- if [ -e /etc/inittab ] ; then
- grep -Eq "^[^#]+.*\<tty$1\>" /etc/inittab
- elif [ -e /etc/ttys ] ; then
- grep -q "^ttyv$(($1 - 1))" /etc/ttys
- else
- return 1
- fi
-}
-
-start() {
- local EXE= NAME= PIDFILE=
- setup_dm
-
- if [ -f /etc/.noxdm ] || get_bootparam "nox" ; then
- einfo "Skipping ${EXE##*/}, /etc/.noxdm found or \"nox\" bootparam passed."
- rm /etc/.noxdm
- return 0
- fi
-
- ebegin "Setting up ${EXE##*/}"
-
- # save the prefered DM
- save_options "service" "${EXE}"
- save_options "name" "${NAME}"
- save_options "pidfile" "${PIDFILE}"
-
- if [ -n "${CHECKVT-y}" ] ; then
- if vtstatic "${CHECKVT:-7}" ; then
- if [ -x /sbin/telinit ] && [ "${SOFTLEVEL}" != "BOOT" ] && [ "${RC_SOFTLEVEL}" != "BOOT" ] ; then
- ewarn "Something is already defined on VT ${CHECKVT:-7}, will start X later"
- telinit a >/dev/null 2>/dev/null
- return 0
- else
- eerror "Something is already defined on VT ${CHECKVT:-7}, not starting"
- return 1
- fi
- fi
- fi
-
- /etc/X11/startDM.sh
- eend 0
-}
-
-stop() {
- local retval=0
- local curvt=
- if [ -t 0 ] ; then
- if type fgconsole >/dev/null 2>/dev/null ; then
- curvt="$(fgconsole 2>/dev/null)"
- else
- curvt="$(tty)"
- case "${curvt}" in
- /dev/ttyv[0-9]*) curvt="${curvt#/dev/ttyv*}" ;;
- *) curvt= ;;
- esac
- fi
- fi
- local myexe="$(get_options "service")"
- local myname="$(get_options "name")"
- local mypidfile="$(get_options "pidfile")"
- local myservice=${myexe##*/}
-
- [ -z "${myexe}" ] && return 0
-
- ebegin "Stopping ${myservice}"
-
- if start-stop-daemon --quiet --test --stop --exec "${myexe}" ; then
- start-stop-daemon --stop --exec "${myexe}" --retry TERM/5/TERM/5 \
- ${mypidfile:+--pidfile} ${mypidfile} \
- ${myname:+--name} ${myname}
- retval=$?
- fi
-
- # switch back to original vt
- if [ -n "${curvt}" ] ; then
- if type chvt >/dev/null 2>/dev/null ; then
- chvt "${curvt}"
- else
- vidcontrol -s "$((${curvt} + 1))"
- fi
- fi
-
- eend ${retval} "Error stopping ${myservice}"
- return ${retval}
-}
-
-# vim: set ts=4 :
diff --git a/x11-base/xorg-server/files/xorg-server-1.9.0-loongson.patch b/x11-base/xorg-server/files/xorg-server-1.9.0-loongson.patch
deleted file mode 100644
index 4351f28..0000000
--- a/x11-base/xorg-server/files/xorg-server-1.9.0-loongson.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff --git a/hw/xfree86/dri/sarea.h b/hw/xfree86/dri/sarea.h
-index 1528cc1..6be12b9 100644
---- a/hw/xfree86/dri/sarea.h
-+++ b/hw/xfree86/dri/sarea.h
-@@ -42,6 +42,8 @@
- /* SAREA area needs to be at least a page */
- #if defined(__alpha__)
- #define SAREA_MAX 0x2000
-+#elif defined(__mips__)
-+#define SAREA_MAX 0x4000
- #elif defined(__ia64__)
- #define SAREA_MAX 0x10000 /* 64kB */
- #else
-diff --git a/hw/xfree86/os-support/linux/lnx_video.c b/hw/xfree86/os-support/linux/lnx_video.c
-index 688106a..1552860 100644
---- a/hw/xfree86/os-support/linux/lnx_video.c
-+++ b/hw/xfree86/os-support/linux/lnx_video.c
-@@ -505,9 +505,10 @@ _X_EXPORT volatile unsigned char *ioBase = NULL;
- _X_EXPORT Bool
- xf86EnableIO(void)
- {
--#if defined(__powerpc__)
-+#if defined(__powerpc__) || defined(__mips__)
- int fd;
- unsigned int ioBase_phys;
-+ extern unsigned int IOPortBase;
- #endif
-
- if (ExtendedEnabled)
-@@ -532,7 +533,22 @@ xf86EnableIO(void)
- #endif
- }
- close(fd);
--#elif !defined(__mc68000__) && !defined(__sparc__) && !defined(__mips__) && !defined(__sh__) && !defined(__hppa__) && !defined(__s390__) && !defined(__arm__) && !defined(__m32r__)
-+#elif defined(__mips__)
-+ fd = open("/dev/mem", O_RDWR);
-+ IOPortBase = (volatile unsigned char *)mmap(0, 0x20000,
-+ PROT_READ | PROT_WRITE, MAP_SHARED, fd,
-+ 0x1fd00000);
-+ if (IOPortBase == MAP_FAILED) {
-+ xf86Msg(X_WARNING,
-+ "xf86EnableIOPorts: Failed to map iobase (%s)\n",
-+ strerror(errno));
-+ return FALSE;
-+ }
-+ close(fd);
-+ xf86Msg(X_WARNING,
-+ "xf86EnableIOPorts: map iobase (%x)\n",
-+ IOPortBase);
-+#elif !defined(__mc68000__) && !defined(__sparc__) && !defined(__sh__) && !defined(__hppa__) && !defined(__s390__) && !defined(__arm__) && !defined(__m32r__)
- if (ioperm(0, 1024, 1) || iopl(3)) {
- if (errno == ENODEV)
- ErrorF("xf86EnableIOPorts: no I/O ports found\n");
diff --git a/x11-base/xorg-server/files/xorg-server-1.9.2.902-loongson.patch b/x11-base/xorg-server/files/xorg-server-1.9.2.902-loongson.patch
deleted file mode 100644
index 4351f28..0000000
--- a/x11-base/xorg-server/files/xorg-server-1.9.2.902-loongson.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff --git a/hw/xfree86/dri/sarea.h b/hw/xfree86/dri/sarea.h
-index 1528cc1..6be12b9 100644
---- a/hw/xfree86/dri/sarea.h
-+++ b/hw/xfree86/dri/sarea.h
-@@ -42,6 +42,8 @@
- /* SAREA area needs to be at least a page */
- #if defined(__alpha__)
- #define SAREA_MAX 0x2000
-+#elif defined(__mips__)
-+#define SAREA_MAX 0x4000
- #elif defined(__ia64__)
- #define SAREA_MAX 0x10000 /* 64kB */
- #else
-diff --git a/hw/xfree86/os-support/linux/lnx_video.c b/hw/xfree86/os-support/linux/lnx_video.c
-index 688106a..1552860 100644
---- a/hw/xfree86/os-support/linux/lnx_video.c
-+++ b/hw/xfree86/os-support/linux/lnx_video.c
-@@ -505,9 +505,10 @@ _X_EXPORT volatile unsigned char *ioBase = NULL;
- _X_EXPORT Bool
- xf86EnableIO(void)
- {
--#if defined(__powerpc__)
-+#if defined(__powerpc__) || defined(__mips__)
- int fd;
- unsigned int ioBase_phys;
-+ extern unsigned int IOPortBase;
- #endif
-
- if (ExtendedEnabled)
-@@ -532,7 +533,22 @@ xf86EnableIO(void)
- #endif
- }
- close(fd);
--#elif !defined(__mc68000__) && !defined(__sparc__) && !defined(__mips__) && !defined(__sh__) && !defined(__hppa__) && !defined(__s390__) && !defined(__arm__) && !defined(__m32r__)
-+#elif defined(__mips__)
-+ fd = open("/dev/mem", O_RDWR);
-+ IOPortBase = (volatile unsigned char *)mmap(0, 0x20000,
-+ PROT_READ | PROT_WRITE, MAP_SHARED, fd,
-+ 0x1fd00000);
-+ if (IOPortBase == MAP_FAILED) {
-+ xf86Msg(X_WARNING,
-+ "xf86EnableIOPorts: Failed to map iobase (%s)\n",
-+ strerror(errno));
-+ return FALSE;
-+ }
-+ close(fd);
-+ xf86Msg(X_WARNING,
-+ "xf86EnableIOPorts: map iobase (%x)\n",
-+ IOPortBase);
-+#elif !defined(__mc68000__) && !defined(__sparc__) && !defined(__sh__) && !defined(__hppa__) && !defined(__s390__) && !defined(__arm__) && !defined(__m32r__)
- if (ioperm(0, 1024, 1) || iopl(3)) {
- if (errno == ENODEV)
- ErrorF("xf86EnableIOPorts: no I/O ports found\n");