summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2016-07-26 02:57:46 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2016-07-26 02:57:46 +0700
commitc731b26174f23830ac6be9684b545602cc57b8ea (patch)
treecced31053d78b2b5c5d429a3ec5d66a45a5bf820 /dev-lua/ldoc
parentmsgpack: update ebuild (diff)
downloadlua-c731b26174f23830ac6be9684b545602cc57b8ea.tar.gz
lua-c731b26174f23830ac6be9684b545602cc57b8ea.tar.bz2
lua-c731b26174f23830ac6be9684b545602cc57b8ea.zip
dev-lua/*: move to EAPI=6 + renewed lua.eclass
Diffstat (limited to 'dev-lua/ldoc')
-rw-r--r--dev-lua/ldoc/ldoc-9999.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/dev-lua/ldoc/ldoc-9999.ebuild b/dev-lua/ldoc/ldoc-9999.ebuild
index 940758c..8ca7c38 100644
--- a/dev-lua/ldoc/ldoc-9999.ebuild
+++ b/dev-lua/ldoc/ldoc-9999.ebuild
@@ -1,16 +1,14 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-VCS="git-r3"
+VCS="git"
+GITHUB_A="stevedonovan"
inherit lua
DESCRIPTION="A LuaDoc-compatible documentation generation system"
HOMEPAGE="https://github.com/stevedonovan/LDoc/"
-SRC_URI=""
-
-EGIT_REPO_URI="https://github.com/stevedonovan/LDoc/"
LICENSE="MIT"
SLOT="0"
@@ -23,14 +21,20 @@ RDEPEND="
DOCS=( doc/doc.md readme.md )
-HTML_DOCS=( doc_html/ ldoc_html/ )
+HTML_DOCS=( doc_html/. ldoc_html/. )
all_lua_prepare() {
local lua="$(lua_get_implementation)"
- cd doc; ${lua} ../ldoc.lua . -d ../doc_html; cd ..
- cd ldoc; ${lua} ../ldoc.lua . -d ../ldoc_html; cd ..
+ mkdir -p doc_html/ ldoc_html/ # for USE=-doc case
+ use doc && (
+ for doc in {,l}doc; do
+ pushd "${doc}" &>/dev/null
+ "${lua}" ../ldoc.lua . -d ../${doc}_html || die "Failed to build in ${doc} dir"
+ popd
+ done
+ )
rm ldoc/{SciTE.properties,config.ld}
}