summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luaexpat/luaexpat-9999.ebuild')
-rw-r--r--dev-lua/luaexpat/luaexpat-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-lua/luaexpat/luaexpat-9999.ebuild b/dev-lua/luaexpat/luaexpat-9999.ebuild
new file mode 100644
index 0000000..48f9238
--- /dev/null
+++ b/dev-lua/luaexpat/luaexpat-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="4"
+
+inherit multilib toolchain-funcs flag-o-matic mercurial eutils
+
+DESCRIPTION="XMPP client library written in Lua."
+HOMEPAGE="http://code.mathewwild.co.uk/"
+EHG_REPO_URI="http://code.matthewwild.co.uk/lua-expat/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1
+ dev-libs/expat"
+DEPEND="${RDEPEND}
+dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i -e "s#^LUA_LIBDIR=.*#LUA_LIBDIR=$(pkg-config --variable INSTALL_CMOD lua)#" "${S}/config"
+ sed -i -e "s#^LUA_DIR=.*#LUA_DIR=$(pkg-config --variable INSTALL_LMOD lua)#" "${S}/config"
+ sed -i -e "s#^LUA_INC=.*#LUA_INC=$(pkg-config --variable INSTALL_INC lua)#" "${S}/config"
+ sed -i -e "s#^EXPAT_INC=.*#EXPAT_INC=/usr/include#" "${S}/config"
+ sed -i -e "s#^LUA_VERSION_NUM=.*#LUA_VERSION_NUM=501#" "${S}/config"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ append-flags -fPIC
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC) -shared" \
+ || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed"
+ dodoc README || die
+ dohtml -r doc/* || die
+}