summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/uuid/uuid-9999.ebuild')
-rw-r--r--dev-lua/uuid/uuid-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-lua/uuid/uuid-9999.ebuild b/dev-lua/uuid/uuid-9999.ebuild
new file mode 100644
index 0000000..ca26735
--- /dev/null
+++ b/dev-lua/uuid/uuid-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VCS="git"
+GITHUB_A="Tieske"
+
+inherit lua
+
+DESCRIPTION="Generates uuids in pure Lua"
+HOMEPAGE="https://github.com/Tieske/uuid"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+RDEPEND="
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=(README.md)
+HTML_DOCS=(doc/.)
+
+each_lua_install() {
+ dolua "src/${PN}.lua"
+}