aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libepoxy/files/musl_no_dlsym.patch')
-rw-r--r--media-libs/libepoxy/files/musl_no_dlsym.patch80
1 files changed, 0 insertions, 80 deletions
diff --git a/media-libs/libepoxy/files/musl_no_dlsym.patch b/media-libs/libepoxy/files/musl_no_dlsym.patch
deleted file mode 100644
index b31ceae4..00000000
--- a/media-libs/libepoxy/files/musl_no_dlsym.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From 0bbdbcdf3917fff68cf96e89b76358e94d20d77c Mon Sep 17 00:00:00 2001
-From: Ross Burton <ross.burton@intel.com>
-Date: Thu, 1 Mar 2018 17:37:42 +0000
-Subject: [PATCH 1/2] meson: add option to enable/disable the test suite
-
----
- meson.build | 5 ++++-
- meson_options.txt | 4 ++++
- 2 files changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index b2ebaef..9632c7a 100644
---- a/meson.build
-+++ b/meson.build
-@@ -242,7 +242,10 @@ libepoxy_inc = [
-
- subdir('include/epoxy')
- subdir('src')
--subdir('test')
-+
-+if get_option('tests')
-+ subdir('test')
-+endif
-
- if get_option('docs')
- doxygen = find_program('doxygen', required: false)
-diff --git a/meson_options.txt b/meson_options.txt
-index b5d7c98..dc30e68 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -15,3 +15,7 @@ option('x11',
- type: 'boolean',
- value: true,
- description: 'Enable X11 support (GLX or EGL-X11)')
-+option('tests',
-+ type: 'boolean',
-+ value: true,
-+ description: 'Build the test suite')
-
-From 85c692f9fe46259b5a85201d96e871ae12db4bc4 Mon Sep 17 00:00:00 2001
-From: Ross Burton <ross.burton@intel.com>
-Date: Thu, 1 Mar 2018 17:39:52 +0000
-Subject: [PATCH 2/2] test: skip tests that require dlvsym if it isn't
- available
-
-dlvsym is a glibc extension so check for it and skip the tests which need dlvsym
-if it isn't present.
----
- test/meson.build | 7 ++++---
- 1 file changed, 4 insertions(+), 3 deletions(-)
-
-diff --git a/test/meson.build b/test/meson.build
-index c5788b4..b97930e 100644
---- a/test/meson.build
-+++ b/test/meson.build
-@@ -1,3 +1,4 @@
-+has_dlvsym = cc.has_function('dlvsym', prefix : '#include<dlfcn.h>')
- has_gles1 = gles1_dep.found()
- has_gles2 = gles2_dep.found()
- build_x11_tests = enable_x11 and x11_dep.found()
-@@ -92,8 +93,8 @@ if build_glx
- [ 'glx_has_extension_nocontext', [ 'glx_has_extension_nocontext.c' ], [], [], true ],
- [ 'glx_static', [ 'glx_static.c' ], [ '-DNEEDS_TO_BE_STATIC'], [ '-static' ], libtype == 'static' ],
- [ 'glx_shared_znow', [ 'glx_static.c', ], [], [ '-Wl,-z,now' ], has_znow ],
-- [ 'glx_alias_prefer_same_name', [ 'glx_alias_prefer_same_name.c', 'dlwrap.c', 'dlwrap.h' ], [], [ '-rdynamic' ], not build_apple ],
-- [ 'glx_gles2', [ 'glx_gles2.c', 'dlwrap.c', 'dlwrap.h' ], [], [ '-rdynamic' ], not build_apple ],
-+ [ 'glx_alias_prefer_same_name', [ 'glx_alias_prefer_same_name.c', 'dlwrap.c', 'dlwrap.h' ], [], [ '-rdynamic' ], not build_apple and has_dlvsym ],
-+ [ 'glx_gles2', [ 'glx_gles2.c', 'dlwrap.c', 'dlwrap.h' ], [], [ '-rdynamic' ], not build_apple and has_dlvsym ],
- ]
-
- foreach test: glx_tests
-@@ -114,7 +115,7 @@ if build_glx
- endif
- endforeach
-
-- if not build_apple
-+ if not build_apple and has_dlvsym
- # GLX/EGL tests
- if build_egl
- glx_egl_sources = [