aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-08-20 04:56:17 +0000
committerMike Frysinger <vapier@gentoo.org>2011-08-20 04:56:17 +0000
commit5888d1b3d53b209cc3f22d9d33f5149909dc5ca1 (patch)
treeadd753ef275b240e59eb879e512fe6e7ce2a5811
parentpatch from Bert Wesarg to separate basename of -p only if it is absulote (diff)
downloadnet-tools-5888d1b3d53b209cc3f22d9d33f5149909dc5ca1.tar.gz
net-tools-5888d1b3d53b209cc3f22d9d33f5149909dc5ca1.tar.bz2
net-tools-5888d1b3d53b209cc3f22d9d33f5149909dc5ca1.zip
fix path to net-features.h
This was causing the %.o rule to get ignored which meant most of the dependencies were ignored. Once that gets fixed, we see that the %.o rule doesn't properly use $(CPPFLAGS). So add that while we're here. Gentoo bug 379715
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 798509d..afd01e6 100644
--- a/Makefile
+++ b/Makefile
@@ -126,8 +126,8 @@ LD = $(CC)
NLIB = -l$(NET_LIB_NAME)
-%.o: %.c config.h version.h intl.h net-features.h $<
- $(CC) $(CFLAGS) -c $<
+%.o: %.c config.h version.h intl.h lib/net-features.h $<
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $<
all: config.h version.h subdirs $(PROGS)