summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2007-02-12 23:08:30 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2007-02-12 23:08:30 +0000
commitd13dbe7465617d95fc1ec7b0c0755b49787819b5 (patch)
treef579acf469760d58eb293b488c45dcd1b3a3b6d8 /net-misc/nx/files
parentRemoving useless "cd ${S}" in src_install() (diff)
downloadnx-d13dbe7465617d95fc1ec7b0c0755b49787819b5.tar.gz
nx-d13dbe7465617d95fc1ec7b0c0755b49787819b5.tar.bz2
nx-d13dbe7465617d95fc1ec7b0c0755b49787819b5.zip
64bit native compilation for nx, warning message cleanups from bug #154132
svn path=/testing/; revision=127
Diffstat (limited to 'net-misc/nx/files')
-rw-r--r--net-misc/nx/files/1.5.0/nx-x11-1.5.0-amd64.patch15
-rw-r--r--net-misc/nx/files/nx-2.1.0-64bit-clean.patch102
-rw-r--r--net-misc/nx/files/nx-2.1.0-deprecated-headers.patch111
-rw-r--r--net-misc/nx/files/nx-2.1.0-invalid-options.patch38
4 files changed, 251 insertions, 15 deletions
diff --git a/net-misc/nx/files/1.5.0/nx-x11-1.5.0-amd64.patch b/net-misc/nx/files/1.5.0/nx-x11-1.5.0-amd64.patch
deleted file mode 100644
index 0c7279b..0000000
--- a/net-misc/nx/files/1.5.0/nx-x11-1.5.0-amd64.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -ru nx-X11-orig/lib/X11/XlcDL.c nx-X11/lib/X11/XlcDL.c
---- nx-X11-orig/lib/X11/XlcDL.c 2006-10-04 16:51:54.000000000 -0600
-+++ nx-X11/lib/X11/XlcDL.c 2006-10-04 16:52:55.000000000 -0600
-@@ -58,10 +58,8 @@
- #ifdef _LP64
- # if defined(__sparcv9)
- # define _MACH64_NAME "sparcv9"
--# elif defined(__ia64__)
--# undef MACH64_NAME
- # else
--# error "Unknown architecture"
-+# undef MACH64_NAME
- # endif /* defined(__sparcv9) */
- # ifdef _MACH64_NAME
- # define _MACH64_NAME_LEN (sizeof (_MACH64_NAME) - 1)
diff --git a/net-misc/nx/files/nx-2.1.0-64bit-clean.patch b/net-misc/nx/files/nx-2.1.0-64bit-clean.patch
new file mode 100644
index 0000000..67dbb76
--- /dev/null
+++ b/net-misc/nx/files/nx-2.1.0-64bit-clean.patch
@@ -0,0 +1,102 @@
+--- nxcomp.old/NXproto.h 2006-06-19 19:55:56.000000000 +0200
++++ nxcomp/NXproto.h 2007-02-12 18:17:41.000000000 +0100
+@@ -26,6 +26,30 @@
+ #include <X11/Xmd.h>
+ #include <X11/Xproto.h>
+
++/*
++ Copied from Xproto.h
++ */
++
++/* For the purpose of the structure definitions in this file,
++we must redefine the following types in terms of Xmd.h's types, which may
++include bit fields. All of these are #undef'd at the end of this file,
++restoring the definitions in X.h. */
++
++#define Window CARD32
++#define Drawable CARD32
++#define Font CARD32
++#define Pixmap CARD32
++#define Cursor CARD32
++#define Colormap CARD32
++#define GContext CARD32
++#define Atom CARD32
++#define VisualID CARD32
++#define Time CARD32
++#define KeyCode CARD8
++#define KeySym CARD32
++
++/* End copied from Xproto.h */
++
+ #define sz_xNXGetControlParametersReq 4
+ #define sz_xNXGetCleanupParametersReq 4
+ #define sz_xNXGetImageParametersReq 4
+@@ -343,9 +367,9 @@
+ CARD8 dstDepth;
+ CARD32 srcLength B32;
+ CARD32 dstLength B32;
+- INT16 srcX B16, srcY B16;
++ CARD16 srcX B16, srcY B16;
+ CARD16 srcWidth B16, srcHeight B16;
+- INT16 dstX B16, dstY B16;
++ CARD16 dstX B16, dstY B16;
+ CARD16 dstWidth B16, dstHeight B16;
+ } xNXPutPackedImageReq;
+
+@@ -463,4 +487,20 @@
+ }
+ #endif
+
++/* Copied from Xproto.h */
++
++/* restore these definitions back to the typedefs in X.h */
++#undef Window
++#undef Drawable
++#undef Font
++#undef Pixmap
++#undef Cursor
++#undef Colormap
++#undef GContext
++#undef Atom
++#undef VisualID
++#undef Time
++#undef KeyCode
++#undef KeySym
++
+ #endif /* NXproto_H */
+diff -ur nx-X11/programs/Xserver/hw/nxagent.old/Millis.c nx-X11/programs/Xserver/hw/nxagent/Millis.c
+--- nx-X11/programs/Xserver/hw/nxagent.old/Millis.c 2006-05-25 11:37:31.000000000 +0200
++++ nx-X11/programs/Xserver/hw/nxagent/Millis.c 2007-02-12 19:10:10.000000000 +0100
+@@ -22,7 +22,7 @@
+ #include "Millis.h"
+
+ #ifdef DDXTIME
+-unsigned long GetTimeInMillis()
++CARD32 GetTimeInMillis()
+ {
+ struct timeval ts;
+
+diff -ur nx-X11/programs/Xserver/hw/nxagent.old/Millis.h nx-X11/programs/Xserver/hw/nxagent/Millis.h
+--- nx-X11/programs/Xserver/hw/nxagent.old/Millis.h 2006-05-22 15:02:16.000000000 +0200
++++ nx-X11/programs/Xserver/hw/nxagent/Millis.h 2007-02-12 19:22:26.000000000 +0100
+@@ -18,7 +18,7 @@
+ #ifndef __Millis_H__
+ #define __Millis_H__
+
+-unsigned long GetTimeInMillis(void);
++#include "os.h"
+
+ const char *GetTimeInMillisAsString(void);
+
+diff -ur lib.old/X11/XlcDL.c lib/X11/XlcDL.c
+--- nx-X11.old/lib/X11/XlcDL.c 2006-06-19 16:20:46.000000000 +0200
++++ nx-X11/lib/X11/XlcDL.c 2007-02-12 06:32:53.000000000 +0100
+@@ -61,7 +61,7 @@
+ # elif defined(__ia64__)
+ # undef MACH64_NAME
+ # else
+-# error "Unknown architecture"
++# undef MACH64_NAME
+ # endif /* defined(__sparcv9) */
+ # ifdef _MACH64_NAME
+ # define _MACH64_NAME_LEN (sizeof (_MACH64_NAME) - 1)
diff --git a/net-misc/nx/files/nx-2.1.0-deprecated-headers.patch b/net-misc/nx/files/nx-2.1.0-deprecated-headers.patch
new file mode 100644
index 0000000..c9741d5
--- /dev/null
+++ b/net-misc/nx/files/nx-2.1.0-deprecated-headers.patch
@@ -0,0 +1,111 @@
+diff -urN BlockCacheSet.cpp BlockCacheSet.cpp
+--- BlockCacheSet.cpp 2006-11-05 13:22:45.963189321 +0000
++++ BlockCacheSet.cpp 2006-11-05 13:23:25.000000000 +0000
+@@ -15,7 +15,9 @@
+ /* */
+ /**************************************************************************/
+
+-#include <iostream.h>
++using namespace std;
++
++#include <iostream>
+ #include "BlockCacheSet.h"
+
+
+diff -urN Loop.cpp Loop.cpp
+--- Loop.cpp 2006-11-05 13:22:45.854205948 +0000
++++ Loop.cpp 2006-11-05 13:23:25.000000000 +0000
+@@ -15,6 +15,8 @@
+ /* */
+ /**************************************************************************/
+
++using namespace std;
++
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+@@ -29,7 +31,7 @@
+ #include <dirent.h>
+ #include <pwd.h>
+
+-#include <fstream.h>
++#include <fstream>
+ #include <fcntl.h>
+
+ #include <sys/types.h>
+diff -urN Message.cpp Message.cpp
+--- Message.cpp 2006-11-05 13:22:45.963189321 +0000
++++ Message.cpp 2006-11-05 13:23:25.000000000 +0000
+@@ -15,8 +15,10 @@
+ /* */
+ /**************************************************************************/
+
++using namespace std;
++
+ #include <stdio.h>
+-#include <fstream.h>
++#include <fstream>
+ #include <unistd.h>
+ #include <string.h>
+
+diff -urN Misc.cpp Misc.cpp
+--- Misc.cpp 2006-11-05 13:22:45.701229285 +0000
++++ Misc.cpp 2006-11-05 13:23:25.000000000 +0000
+@@ -15,7 +15,9 @@
+ /* */
+ /**************************************************************************/
+
+-#include <iostream.h>
++using namespace std;
++
++#include <iostream>
+ #include <stdio.h>
+ #include <ctype.h>
+ #include <stdlib.h>
+diff -urN Misc.h Misc.h
+--- Misc.h 2006-11-05 13:22:45.643238132 +0000
++++ Misc.h 2006-11-05 13:23:25.000000000 +0000
+@@ -18,8 +18,10 @@
+ #ifndef Misc_H
+ #define Misc_H
+
+-#include <iostream.h>
+-#include <fstream.h>
++using namespace std;
++
++#include <iostream>
++#include <fstream>
+
+ #include <errno.h>
+ #include <string.h>
+diff -urN Proxy.cpp Proxy.cpp
+--- Proxy.cpp 2006-11-05 13:22:45.856205642 +0000
++++ Proxy.cpp 2006-11-05 13:23:25.000000000 +0000
+@@ -15,10 +15,12 @@
+ /* */
+ /**************************************************************************/
+
++using namespace std;
++
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+-#include <fstream.h>
++#include <fstream>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
+diff -urN Split.cpp Split.cpp
+--- Split.cpp 2006-11-05 13:22:45.797214643 +0000
++++ Split.cpp 2006-11-05 13:23:25.000000000 +0000
+@@ -15,7 +15,9 @@
+ /* */
+ /**************************************************************************/
+
+-#include <fstream.h>
++using namespace std;
++
++#include <fstream>
+ #include <unistd.h>
+ #include <string.h>
+ #include <sys/stat.h>
diff --git a/net-misc/nx/files/nx-2.1.0-invalid-options.patch b/net-misc/nx/files/nx-2.1.0-invalid-options.patch
new file mode 100644
index 0000000..17e4f43
--- /dev/null
+++ b/net-misc/nx/files/nx-2.1.0-invalid-options.patch
@@ -0,0 +1,38 @@
+--- configure.in 2006-11-04 19:37:56.000000000 +0000
++++ configure.in 2006-11-04 19:38:23.000000000 +0000
+@@ -52,35 +52,6 @@
+ AC_PROG_CC
+ AC_LANG_CPLUSPLUS
+
+-dnl Check whether option -Wno-deprecated
+-dnl is needed by GCC compiler.
+-
+-AC_MSG_CHECKING([whether compiler needs -Wno-deprecated])
+-gcc_version=`${CC} --version | grep 'gcc (GCC) [[3-4]].' | head -n 1`
+-case "${gcc_version}" in
+- gcc*)
+- AC_MSG_RESULT([yes])
+- CXXFLAGS="$CXXFLAGS -Wno-deprecated"
+- ;;
+-
+- *)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+-
+-AC_MSG_CHECKING([whether compiler accepts -Wmissing-declarations and -Wnested-externs])
+-gcc_version=`${CC} --version | grep 'gcc (GCC) [[3-4]].' | head -n 1`
+-case "${gcc_version}" in
+- gcc*)
+- AC_MSG_RESULT([no])
+- ;;
+-
+- *)
+- AC_MSG_RESULT([yes])
+- CXXFLAGS="$CXXFLAGS -Wmissing-declarations -Wnested-externs"
+- ;;
+-esac
+-
+ dnl Check for BSD compatible install.
+
+ AC_PROG_INSTALL