aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-03-19 20:49:50 +0100
committerFabian Groffen <grobian@gentoo.org>2019-03-19 20:49:50 +0100
commit741684c0be529d9cb7ea91a48b801ca6859d2e9d (patch)
treeb08126a02591297303f6cf91c4fa1e9a25321c99 /configure
parenttravis: touch files in order not to trigger autoreconf (diff)
downloadportage-utils-741684c0be529d9cb7ea91a48b801ca6859d2e9d.tar.gz
portage-utils-741684c0be529d9cb7ea91a48b801ca6859d2e9d.tar.bz2
portage-utils-741684c0be529d9cb7ea91a48b801ca6859d2e9d.zip
build: fix misc issues found on Linux
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure b/configure
index ad96730..ce1fbde 100755
--- a/configure
+++ b/configure
@@ -35001,6 +35001,42 @@ else
fi
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -Wno-expansion-to-defined" >&5
+$as_echo_n "checking whether C compiler accepts -Wno-expansion-to-defined... " >&6; }
+if ${ax_cv_check_cflags___Wno_expansion_to_defined+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+
+ ax_check_save_flags=$CFLAGS
+ CFLAGS="$CFLAGS -Wno-expansion-to-defined"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+
+int
+main ()
+{
+
+ ;
+ return 0;
+}
+_ACEOF
+if ac_fn_c_try_compile "$LINENO"; then :
+ ax_cv_check_cflags___Wno_expansion_to_defined=yes
+else
+ ax_cv_check_cflags___Wno_expansion_to_defined=no
+fi
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+ CFLAGS=$ax_check_save_flags
+fi
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___Wno_expansion_to_defined" >&5
+$as_echo "$ax_cv_check_cflags___Wno_expansion_to_defined" >&6; }
+if test "x$ax_cv_check_cflags___Wno_expansion_to_defined" = xyes; then :
+ as_fn_append CFLAGS " -Wno-expansion-to-defined"
+else
+ :
+fi
+
+
ac_config_files="$ac_config_files Makefile libq/Makefile autotools/gnulib/Makefile tests/atom_explode/Makefile tests/copy_file/Makefile tests/mkdir/Makefile tests/rmspace/Makefile"