aboutsummaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-03-09 13:22:35 -0800
committerZac Medico <zmedico@gentoo.org>2024-03-09 13:22:35 -0800
commiteea598a20b2db5ecbe3975dc96885f529ae54c1c (patch)
tree9e05462b5981ccca12b9a247c856e7f9b7948069 /bin
parentphase-functions: prematurely delete WORKDIR if FEATURES=merge-wait (diff)
downloadportage-eea598a20b2db5ecbe3975dc96885f529ae54c1c.tar.gz
portage-eea598a20b2db5ecbe3975dc96885f529ae54c1c.tar.bz2
portage-eea598a20b2db5ecbe3975dc96885f529ae54c1c.zip
__dyn_install: Record REPO_REVISIONS in build-info
Record REPO_REVISIONS as a json object that maps repo name to revision for an ebuild's source repository and any repositories that eclasses were inherited from: $ cat /var/tmp/portage/sys-apps/portage-3.0.63/build-info/REPO_REVISIONS {"gentoo": "34875e30e73e33d3597d1101cdf97dc22729b268"} Ultimately the intention is to expose this information in binhost metadata so that clients can select consistent revisions of source repositories. Bug: https://bugs.gentoo.org/924772 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'bin')
-rw-r--r--bin/phase-functions.sh1
1 files changed, 1 insertions, 0 deletions
diff --git a/bin/phase-functions.sh b/bin/phase-functions.sh
index ab130a3be..9ff555440 100644
--- a/bin/phase-functions.sh
+++ b/bin/phase-functions.sh
@@ -719,6 +719,7 @@ __dyn_install() {
cp "${EBUILD}" "${PF}.ebuild"
[[ -n "${PORTAGE_REPO_NAME}" ]] && echo "${PORTAGE_REPO_NAME}" > repository
+ [[ -n ${PORTAGE_REPO_REVISIONS} ]] && echo "${PORTAGE_REPO_REVISIONS}" > REPO_REVISIONS
if has nostrip ${FEATURES} ${PORTAGE_RESTRICT} || has strip ${PORTAGE_RESTRICT}; then
>> DEBUGBUILD
fi