diff options
author | Mike Gilbert <floppym@gentoo.org> | 2022-06-06 11:29:06 -0400 |
---|---|---|
committer | Mike Gilbert <floppym@gentoo.org> | 2022-06-06 11:31:33 -0400 |
commit | 03821d46e232d9823123fb1603154523798efaa0 (patch) | |
tree | 062705f1de6b757b2426fcf78ae3ce2bba3777db /tox.ini | |
parent | Manifest: Fix ("size",) tuple (diff) | |
download | portage-03821d46e232d9823123fb1603154523798efaa0.tar.gz portage-03821d46e232d9823123fb1603154523798efaa0.tar.bz2 portage-03821d46e232d9823123fb1603154523798efaa0.zip |
Add script to call pylint on all python files
This gives us a simple way to call pylint from tox.ini.
Our previous hack would call pylint on non-python files (shell scripts),
and only went unnoticed because we have most errors disabled in
pylintrc.
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'tox.ini')
-rw-r--r-- | tox.ini | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -19,5 +19,5 @@ deps = setenv = PYTHONPATH={toxinidir}/lib commands = - pylint: bash -c 'rm -rf build && PYTHONPATH=$PWD/lib pylint bin/* lib/*' + pylint: ./run-pylint python -b -Wd setup.py test |