aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.gpyutils')
-rw-r--r--Makefile.gpyutils12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.gpyutils b/Makefile.gpyutils
index 75fee4e..fafc1ba 100644
--- a/Makefile.gpyutils
+++ b/Makefile.gpyutils
@@ -22,12 +22,22 @@ upgr_txt = $(upgr_base) $(upgr_streq)
upgr_dot = $(patsubst %.txt,%.dot,$(upgr_txt))
upgr_svg = $(patsubst %.dot,%.svg,$(upgr_dot))
# add new impls here if not stable yet, to avoid insanely huge generation times
-upgr_all = $(upgr_txt) $(upgr_dot) $(upgr_svg)
+upgr_all = $(upgr_txt) $(upgr_dot) $(upgr_svg) $(outdir)/312-to-313.txt
all = $(upgr_all)
all: $(all)
+$(outdir)/312-to-313.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl -m python3_12 python3_13 > $@.new
+ mv $@.new $@
+
+$(outdir)/312-to-313-stablereq.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl -m -s python3_12 python3_13 > $@.new
+ mv $@.new $@
+
$(outdir)/311-to-312.txt: $(timestamp)
mkdir -p $(outdir)
gpy-upgrade-impl -m python3_11 python3_12 > $@.new